Bug 52055 - Installer hangs when attempting to boot in rescue mode
Installer hangs when attempting to boot in rescue mode
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
7.1
i686 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
: 52056 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-08-19 18:08 EDT by William M. Quarles
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-01-15 15:45:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description William M. Quarles 2001-08-19 18:08:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12 i686; Nav)

Description of problem:
RedHat Linux OS 7.1 is already installed on our system.  We have kept up to
date with the Errata updates from RedHat, so all of the ix86 pacakges are
installed on our system.  Whenwe try to boot from the OS 7.1 Disc 1, then
go into rescue mode, the machine boots with the penguin logo loads the
kernel.  It asks from the language and keyboard type.   After being
entered, a blue screen is displayed, which starts feeding black again from
the bottom, with the text "Running Anaconda, Please wait..."  The computer
reads from the disc again a litte, then from one of the hard drives, then
stops.  The system will hang here indefinitely.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Upgrade from Linux 6.2 to 7.1 on a Pentium III system.
2. Install all update rpms for i386, i686, and noarch, except for
kernel-2.4.3-12.i386.rpm,  kernel-2.4.3-12.i686.rpm,
kernel-enterprise-2.4.3-12.i386.rpm, and kernel-smp-2.4.3-12.i686.rpm
3. Reboot from Linux 7.1 installation Disc 1
4. Start in rescue mode "linux rescue"
5. Choose English as the language and US as the keyboard when prompted.

Actual Results:  System hangs displaying "Running Anaconda, Please wait..."

Expected Results:  Filesystems should be mounted, and the command prompt
should be displayed, allowing the user to interface with the computer.

Additional info:

We were able to run rescue mode before upgrading to Linux OS 7.1.  However,
we obviously cannot now, so some change caused this problem between then
and now.  This is obviously an important thing to fix, because being able
to boot into rescue mode is important if there is a problem with the
system.

We can still load the graphical-mode installer, if that's useful to know.

The only other changes we have made that I can think of might be relevant
are:
- Got rid of our old swap partition, and put another one on a new drive. 
Size of the partition is around 770 MB.  So our linux software is all on
hda, the swap partition is on hdd.
- Upgraded from 128 MB of SDRAM to 384 MB of SDRAM.  The system bus is 100
MHz, the new DIMM that was installed is actually 133 MHz, but has
variable-speed EEPROMS
- Substituted our old IDE cables for ATA-33/66/100 compatible cables. 
During this process, jumpers on the two hard disks on controller 0 were
found to be wrong (who knows why Linux put up with it before?), corrected
for proper Master/Slave relationship.

The computer boots fine from its own hard drive.  It can also boot from the
6.2 installation CD-ROM, and can be run in rescue mode off of there (still
not a very good workaround, however).

I tried burning a new Disc 1 with the image from the ftp site, it
experienced the same problem as our original Disc 1 that we installed our
upgrade from.
Comment 1 William M. Quarles 2001-08-19 19:13:28 EDT
*** Bug 52056 has been marked as a duplicate of this bug. ***
Comment 2 Matt Wilson 2001-08-20 09:51:03 EDT
try booting with "linux ide=nodma" at the boot: prompt
Comment 3 William M. Quarles 2001-08-21 17:05:06 EDT
Yes, it does work, but ou problem was with RESCUE MODE.  Our problem was most
specifically **NOT** WITH GRAPHICAL INSTALLATION MODE.
Comment 4 Brent Fox 2001-08-29 15:40:05 EDT
So when the system hangs while loading anaconda, can you press <Alt><F4> and see
if there are any interesting error messages?
Comment 5 William M. Quarles 2001-08-29 16:52:20 EDT
I have removed some of the out put, because it doesn't all seem relevant.  Here
is what seemed most alarming.

<Beginning>
...
...
<6>PCI: Found IRQ 11 for device 00:11.0
<6>PCI: The same IRQ used for device 00:07.2
...
...
<same two lines as above appear again>
...
...
<7>ISO 9660 Extensions:RRIP_1991A
<4>Unable to identify CD-ROM format.
<6>raid0 personality registered as nr2
<6>raid1 personality registered as nr3
<6>raid5: measuring checksumming speed
<4>	8regs	:	825.600 MB/sec
<4>	32regs	:	461.200 MB/sec
<4>	pII_mmx	:	1128.000 MB/sec
<4>	p5_mmx	:	1170.800 MB/sec
<4>raid5: using function: p5_mmx (1170.800 MB/sec)
<4>raid5 personality registered as nr4
<Ending>

I know that there are two elements to the PCI bus that share the same IRQ as
standard operation but I don't know enough about it to see whether or not that
is a problem.  I don't know why this message comes up twice.  The CD-ROM format
error obviously seems like a problem.  We also don't have any RAID devices
installed, just EIDE.
Comment 6 Michael Fulbright 2001-08-31 11:01:58 EDT
Please boot adding 'nomount' to the command line when going into rescue mode. 
Let us know if that helps.  Also, the output on VC3 would be helpful at the time
it hangs.
Comment 7 William M. Quarles 2001-09-01 21:14:29 EDT
I was not able to find a single line that contained "vc3" in the messages using
Alt+F4 when I tried booting linux rescue again normally.  The nomount option
worked, insofar as it gave me a shell prompt, but doing Alt+F4 displayed the
same mesages.  I also experienced some problems with apache and an experimental
kernel module after doing this and rebooting, but I suspect that was caused by
changes made by others to the system that I will have to track down and fix.
Comment 8 Jeremy Katz 2001-09-05 22:32:13 EDT
The output on VC3 can be found by pressing Alt+F3.  Any output from here when it
hangs would be usfeul in tracking down the problem.
Comment 9 William M. Quarles 2001-09-09 14:40:57 EDT
Here is everything that was viewable on the monitor after pressing Alt+F4:

--------------

* looking for video cards requiring agpart module
* found video card controller unknown
* in startPcmcia()
* pcmcia probe returned: |PCI bridge probe: not found.
Intel PCIC probe: not found.
Databook TCIC-2 probe: not found.
|
* no pcic controller found
* probing buses
* finished bus probing
* found suggestion of agpart
* found suggestion of 3c59x
* found 3c59x device
* found suggestion of usb-uhci
* found devices justProbe is 0
* going to insmod 3c59x.o (path is NULL)
* trying to mount device hdc
* loopfd is 9
* getting ready to spawn shell now
* probing buses
* finished bus probing
* found suggestion of 3c59x
* found 3c59x device
* found suggestion of usb-uhci
* found devices justProbe is 0
* going to insmod raid0.o (path is NULL)
* going to insmod raid0.o (path is NULL)
* going to insmod raid1.o (path is NULL)
* going to insmod xor.o (path is NULL)
* going to insmod raid5.o (path is NULL)
* going to insmod fat.o (path is NULL)
* going to insmod msdos.o (path is NULL)
* going to insmod vfat.o (path is NULL)
* going to insmod ext3.o (path is NULL)
* looking for USB mouse...
* 127 keymaps are available
* loaded 9 keymap tables

--------------

Any repetitions, as in the preivous submission I made, are real and are not a 
tpyographical error on my part.
Comment 10 Brent Fox 2001-10-17 16:21:43 EDT
I don't see anything besides the IRQ messages from VC4 that seem concerning.  To
find out what devices are sharing that IRQ, can you boot into the system
normally and attach the output of 'lspci' and 'cat /proc/interrupts'?
Comment 11 Brent Fox 2001-10-27 10:22:04 EDT
Any more info here?
Comment 12 William M. Quarles 2001-10-27 11:26:34 EDT
Well, I've been rather busy lately, as it seems you have been since it has 
taken you a while to respond to my last posting.  Mostly dealing with problems 
of Windows NT and its habit of randomly obtaining worms on a frequent basis 
late this summer and fall.

Give me another week or two and I will post the 'lspci' 
and 'cat /proc/interrupts' ouputs.
Comment 13 Brent Fox 2001-10-27 12:03:48 EDT
Ok.  Good luck with that NT thing.  ;)
Comment 14 Brent Fox 2001-11-13 15:25:01 EST
Any progress?
Comment 15 William M. Quarles 2001-11-21 10:03:00 EST
Well, our Linux box has had huge filsystem errors that are corrected yet keep
coming back, but I have managed to get this much info for you:

[root@mach quarles]# /sbin/lspci
00:00.0 Host bridge: Intel Corporation 440BX/ZX - 82443BX/ZX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corporation 440BX/ZX - 82443BX/ZX AGP bridge (rev 03)
00:07.0 ISA bridge: Intel Corporation 82371AB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corporation 82371AB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corporation 82371AB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corporation 82371AB PIIX4 ACPI (rev 02)
00:0e.0 Communication controller: National Instruments PCI-GPIB (rev 01)
00:0f.0 PCI bridge: Digital Equipment Corporation DECchip 21152 (rev 03)
00:11.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 24)
01:00.0 VGA compatible controller: ATI Technologies Inc 3D Rage Pro AGP 1X/2X
(rev 5c)
[root@mach quarles]# cat /proc/interrupts
           CPU0       
  0:      43115          XT-PIC  timer
  1:        694          XT-PIC  keyboard
  2:          0          XT-PIC  cascade
  5:      13353          XT-PIC  Crystal audio controller
  8:          1          XT-PIC  rtc
 10:          0          XT-PIC  gpib
 11:      13752          XT-PIC  usb-uhci, eth0
 12:      22669          XT-PIC  PS/2 Mouse
 14:      11733          XT-PIC  ide0
 15:      12695          XT-PIC  ide1
NMI:          0 
LOC:          0 
ERR:          0
MIS:          0
[root@mach quarles]# 

So I guess our USB controller and our ehternet card are sharing the same IRQ.  I
honestly would have never guessed that, since we didn't change anything on the
system that might do that.

I'll change it to NOTABUG and figure out how to solve this problem.
Comment 16 William M. Quarles 2001-11-21 10:12:28 EST
I just thought of something:

USB support wasn't available before 7.0, right?  We upgraded from 6.2 to 7.1. 
The rescue mode DID work before the 7.1 upgrade, but DID NOT work afterward.  It
seems that maybe this is a problem with the upgrade process, that it sets the
USB controller to a default IRQ rather than finding an open one.

Go ahead and close this again if you disagree.
Comment 17 William M. Quarles 2001-11-21 10:42:33 EST
Sorry, I keep having thoughts. Last time today, I swear.  I tried disabling the
ehternet adaptor in the BIOS (since it is integrated), and trying to boot of the
CD-ROM in rescue mode again.  It still hung, and VC4 did not show any IRQ conflicts.
Comment 18 Michael Fulbright 2002-01-15 14:13:46 EST
This issue seems resolved - you were able to get into rescue mode with the
'nomount' option, right?
Comment 19 Brent Fox 2002-01-26 22:50:55 EST
Closing due to inactivity.  Please reopen if you have more information.

Note You need to log in before you can comment on or make changes to this bug.