This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 477890 - rfcomm does not bind automatically
rfcomm does not bind automatically
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
10
i386 Linux
low Severity low
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 529027 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-24 17:12 EST by Thomas Hartwig
Modified: 2009-10-14 14:10 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-24 13:08:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
bluetooth-rfcomm-bind-all.patch (760 bytes, patch)
2009-02-19 15:14 EST, John W. Linville
no flags Details | Diff

  None (edit)
Description Thomas Hartwig 2008-12-24 17:12:04 EST
Description of problem:
After an upgrade to F10, I have to bind the rfcomm devices manually by hand:
#: rfcomm bind rfcomm0

Version-Release number of selected component (if applicable):
bluez-4.19-1

How reproducible:
Define rfcomm devices and restart bluetooth. Dev devices will not be created by default.

Steps to Reproduce:
1. Edit /etc/bluetooth/rfcomm.conf
2. Restart /etc/init.d/bluetooth
3. Check if /dev/rfcomm0 exists.
  
Actual results:
Devices are not created.

Expected results:
Devices should be created.
Comment 1 Patrick Steiner 2009-02-12 01:58:52 EST
I also have got the same problem on my F10 machines.
Comment 2 Thomas Hartwig 2009-02-12 02:22:21 EST
Sample how to bind manually for all users suffering from this, might be possible to integrate this into the bluetooth init script.

#: /usr/bin/rfcomm bind rfcomm0
Comment 3 Patrick Steiner 2009-02-12 05:22:00 EST
The problem ist, that there is no "rfcomm bind all" command in the init-script.

Fedora 9 had this command in its init-script.

Does anybody know why this i removed?
Comment 4 John W. Linville 2009-02-19 15:14:13 EST
Created attachment 332632 [details]
bluetooth-rfcomm-bind-all.patch

Bastien, this mirrors what the script looked-like in F-9.  Any reason not to apply it to F-10 and devel branches of the bluetooth package?
Comment 5 Bastien Nocera 2009-04-29 06:29:35 EDT
Split it off in a separate -compat sub-package. Could you please test this build, and let us know whether it works for you:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1328268
Comment 6 Thomas Hartwig 2009-04-29 06:54:41 EDT
Thanks Bastian, tested your split packages and it worked. Did not see the new rfcomm init script right in the start, but then all did go fine.
From my side you can close this to be fixed in the next releases.
Comment 7 Michael Class 2009-10-13 09:59:51 EDT
Hello,

in Rawhide as of Oct 13th, 2009 there is again (or still) the "rfcomm bind all" missing. I have to manually do this to get the as "bind yes" configured bluetooth devices. (e.g. /dev/rfcomm0 only appears once I have entered "rfcomm bind all")

The startup script of bluetooth looks a lot differnt now, so the patch being part of the description above might not be relevant any more. 

Cheers,

Michael
Comment 8 John W. Linville 2009-10-13 10:22:16 EDT
Michael, did you install the "bluez-compat" package?  That looks to be the intended use now.
Comment 9 Michael Class 2009-10-13 10:38:23 EDT
Thank you John!

Yes I did not install the "bluez-compat" package. This seems to fix the issue (after enabling rfcomm service). 

Why is bluez-compat not installed by default? The template file /etc/bluetooth/rfcomm.conf does imply that "bind yes" would automatically bind at startup. So probably a comment mentioning that "bluez-compat" is needed for this would be helpful. Currently it is not following the "principle of least astonishment"  ;-)

Anyways, thank you!
Comment 10 Bastien Nocera 2009-10-14 14:10:06 EDT
*** Bug 529027 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.