Bug 477976 - MTU not set correctly for 6to4
MTU not set correctly for 6to4
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
9
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-26 15:44 EST by Allen Kistler
Modified: 2014-03-16 23:16 EDT (History)
2 users (show)

See Also:
Fixed In Version: 8.86.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-05 13:43:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for /etc/sysconfig/network-scripts/network-functions-ipv6 (478 bytes, patch)
2008-12-26 15:44 EST, Allen Kistler
no flags Details | Diff

  None (edit)
Description Allen Kistler 2008-12-26 15:44:24 EST
Created attachment 327863 [details]
Patch for /etc/sysconfig/network-scripts/network-functions-ipv6

Description of problem:
MTU of a 6to4 tunnel setup by /etc/ppp/ip-up.ipv6to4 has an incorrect value.  The bug was tracked to a file provided by initscripts for IPv6.  (See "Additional info" for discussion.)

Version-Release number of selected component (if applicable):
initscripts-8.76.4-1.i386

How reproducible:
Always

Steps to Reproduce:
1. Configure 6to4 to use ppp connection (DSL) from /etc/ppp
2. Run /etc/ppp/ip-up.ipv6to4
3. Observe MTU with "ifconfig tun6to4"

Actual results:
MTU is 1480

Expected results:
MTU should be 1472, which 20 less than the MTU of ppp0

Additional info:
I tracked the bug to /etc/sysconfig/network-scripts/network-functions-ipv6.

The routine ipv6_set_mtu writes the correct value to /proc/sys/net/ipv6/conf/tun6to4/mtu using sysctl, so the MTU is calculated correctly, but set ineffectively.

The corresponding function for IPv4 uses /sbin/ip to set the MTU.

Changing the call to ipv6_exec_sysctl into a call to ipv6_exec_ip (and generally getting rid of all references to /proc in ipv6_set_mtu) produces the expected result and doesn't appear to break anything else, either.

Patch attached.

Although this bug is filed against F9, the same bug probably exists in F10, although I haven't checked.
Comment 1 Allen Kistler 2008-12-30 00:11:11 EST
I verified that the bug does exist in F10, as well.  I opened Bug 478441 with an F10-appropriate patch file attached.
Comment 2 Bill Nottingham 2009-01-05 13:43:45 EST

*** This bug has been marked as a duplicate of bug 478441 ***
Comment 3 Fedora Update System 2009-04-02 14:05:04 EDT
initscripts-8.86.1-1 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/initscripts-8.86.1-1
Comment 4 Fedora Update System 2009-04-03 00:16:44 EDT
initscripts-8.86.2-1 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/initscripts-8.86.2-1
Comment 5 Fedora Update System 2009-04-22 16:23:14 EDT
initscripts-8.86.3-1 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.