Bug 478441 - MTU not set correctly for 6to4
MTU not set correctly for 6to4
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: initscripts (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-30 00:08 EST by Allen Kistler
Modified: 2014-03-16 23:16 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-05 13:47:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for network-functions-ipv6 (478 bytes, patch)
2008-12-30 00:08 EST, Allen Kistler
no flags Details | Diff

  None (edit)
Description Allen Kistler 2008-12-30 00:08:27 EST
Created attachment 327952 [details]
Patch for network-functions-ipv6

Description of problem:
MTU of a 6to4 tunnel setup by /etc/ppp/ip-up.ipv6to4 has an incorrect value.  The bug was tracked to a file provided by initscripts for IPv6.  (This bug is the F10 version of Bug 477976, which was filed for F9.  See "Additional info" for discussion.)

Version-Release number of selected component (if applicable):
initscripts-8.86-1.i386

How reproducible:
Always

Steps to Reproduce:
1. Configure 6to4 to use ppp connection (DSL) from /etc/ppp
2. Run /etc/ppp/ip-up.ipv6to4
3. Observe MTU with "ifconfig tun6to4"

Actual results:
MTU is 1480

Expected results:
MTU should be 1472, which 20 less than the MTU of ppp0

Additional info:
I tracked the bug to /etc/sysconfig/network-scripts/network-functions-ipv6.

The routine ipv6_set_mtu writes the correct value to
/proc/sys/net/ipv6/conf/tun6to4/mtu using sysctl, so the MTU is calculated correctly, but set ineffectively.

The corresponding function for IPv4 uses /sbin/ip to set the MTU.

Changing the call to ipv6_exec_sysctl into a call to ipv6_exec_ip (and generally getting rid of all references to /proc in ipv6_set_mtu) produces the expected result and doesn't appear to break anything else, either.

Patch attached.  With a fuzz of 2, this patch is identical to the one submitted for Bug 477976 in F9.  (This patch was generated entirely on F10, though, so there's no fuzz to apply it.)
Comment 1 Bill Nottingham 2009-01-05 13:43:45 EST
*** Bug 477976 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2009-01-05 13:47:50 EST
http://git.fedorahosted.org/git/?p=initscripts.git;a=commitdiff;h=fadc8aa2871eb4331beb8c9db76310269bc03542

Cherry-picked to F10 & F9 branches, although there aren't updates scheduled for those releases currently.
Comment 3 Allen Kistler 2009-01-08 20:09:10 EST
I haven't seen a package show up in Rawhide with the update, but I can wait until F11 to verify the fix (i.e., not file another bug if it doesn't exist).  I may be the only person in the world who cares about PPPoE and IPv6 together now (umm ...), but it seems reasonable to expect it shouldn't always remain so.

Note You need to log in before you can comment on or make changes to this bug.