Bug 477993 - system-config-display crash reading xorg.conf: NoneType no attribute device
system-config-display crash reading xorg.conf: NoneType no attribute device
Status: CLOSED DUPLICATE of bug 480534
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2008-12-26 21:12 EST by Philippe Waroquiers
Modified: 2009-05-21 16:18 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-04-02 12:10:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Philippe Waroquiers 2008-12-26 21:12:35 EST
Description of problem:
system-config-display crash when starting from existing xorg.conf

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. have an xorg.conf that looks like:
Section "Device"
	Identifier "Videocard0"
	Driver "vesa"

2. start system-config-display
Actual results:
$ system-config-display
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 312, in <module>
    hardware_state = XF86HardwareState(xconfig)
  File "/usr/lib/python2.5/site-packages/rhpxl/xhwstate.py", line 174, in __init__
  File "/usr/lib/python2.5/site-packages/rhpxl/xhwstate.py", line 260, in init_from_xconfig
    if screen.device:
AttributeError: 'NoneType' object has no attribute 'device'

Expected results:
a window should start

Additional info:
adding the option --reconfig bypasses the problem
Comment 1 Matt Castelein 2009-01-23 21:23:43 EST
I ran into this also, while trying to use kmod-nvidia, to find a solution to bug 476602.  Now I have problems fixing problems!
Comment 2 Adam Williamson 2009-04-02 12:10:05 EDT
480534 looks more popular :)

*** This bug has been marked as a duplicate of bug 480534 ***
Comment 3 jd1008 2009-05-21 16:18:22 EDT
After a full yum update on Fedora 10, I am having the very same problem reported by this bug. What makes this bug so annoying is that I am running FC10 under 
virtualbox. The default display size of the screen is tiny!!!
I am unable to expandit, enlarge it or re-config it.
F11 is about to be released, and there is still no fix for this bug in F10!!!
Well, I guess Fedora is permanently experimental :)

Note You need to log in before you can comment on or make changes to this bug.