Bug 478358 - Writer locks up at "Save As"
Writer locks up at "Save As"
Status: CLOSED DUPLICATE of bug 477174
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
:
: 477970 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-28 16:42 EST by Pete Zaitcev
Modified: 2008-12-30 08:48 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-30 08:48:05 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pete Zaitcev 2008-12-28 16:42:52 EST
Description of problem:

Writer locks up when doing "Save As...".

Version-Release number of selected component (if applicable):

openoffice.org-base-core-3.0.1-14.2.fc11.x86_64
openoffice.org-writer-3.0.1-14.2.fc11.x86_64
openoffice.org-writer-core-3.0.1-14.2.fc11.x86_64

How reproducible:

100%

Steps to Reproduce:
1. Start Writer
2. Enter some small text
3. Select menu "Save As"
  
Actual results:

A hang

Expected results:

A dialog allowing to save

Additional info:
Comment 1 Caolan McNamara 2008-12-29 18:19:30 EST
It doesn't "lock up" for me, so... 

I assume that e.g. firefox or gedit doesn't lock up the same way ?
can you gdb attach to the process and whack ctrl+c and get a backtrace ? 

I suspect bug 477174 may be in play, but merely because it's the bug of the day.
Comment 2 Caolan McNamara 2008-12-29 18:24:01 EST
*** Bug 477970 has been marked as a duplicate of this bug. ***
Comment 3 Horst H. von Brand 2008-12-29 20:15:44 EST
OK, tried the above steps.

It still hangs when doing "Save as", and trying to enter another directory (i.e., while in ~ trying to save into /tmp). When in /tmp, and trying to save into /tmp it does work.

Tried the same in gedit-2.25.2-2.fc11.x86_64: In ~ opened gedit, wrote some junk into the buffer, went to File --> Save as, told it to save into "/tmp/whatever.txt". Went through without a hitch, the contents of the file are OK.

BTW, /home, /tmp are different filesystems here. both ext3 over LVM. Yep, trying to save from oowriter to another directory on the same filesystem works fine.
Comment 4 Pete Zaitcev 2008-12-29 22:07:13 EST
I have the same symptoms as Horst too, saving to another directory hangs.
I just didn't want to confuse the issue. The Save As issue is difficult
to work around, but I can move files between directories.
Comment 5 Pete Zaitcev 2008-12-29 22:11:32 EST
First run with gdb, without debuginfo:

#0  0x0000003de440db14 in __lll_lock_wait () from /lib64/libpthread.so.0
#1  0x0000003de440b850 in pthread_cond_broadcast@@GLIBC_2.3.2 ()
   from /lib64/libpthread.so.0
#2  0x0000003ab7e4c327 in ?? () from /usr/lib64/libX11.so.6
#3  0x0000003ab7e4c69d in ?? () from /usr/lib64/libX11.so.6
#4  0x0000003ab7e4cf59 in _XReadEvents () from /usr/lib64/libX11.so.6
#5  0x0000003ab7e2b864 in XIfEvent () from /usr/lib64/libX11.so.6
#6  0x0000003abba4ba94 in gdk_x11_get_server_time ()
   from /usr/lib64/libgdk-x11-2.0.so.0
#7  0x0000003abc445019 in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
#8  0x0000003abc44641b in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
#9  0x0000003abc44666e in gtk_clipboard_set_with_owner ()
   from /usr/lib64/libgtk-x11-2.0.so.0
#10 0x0000003abc2b71dc in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
#11 0x0000003abc2da6ce in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
#12 0x0000003abc2b34ef in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
#13 0x0000003abc2da5f1 in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
#14 0x000000328e60b82d in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#15 0x000000328e6222f4 in ?? () from /lib64/libgobject-2.0.so.0
#16 0x000000328e623d09 in g_signal_emit_valist ()
   from /lib64/libgobject-2.0.so.0
#17 0x000000328e624273 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#18 0x0000003abc430982 in gtk_widget_grab_focus ()
   from /usr/lib64/libgtk-x11-2.0.so.0
#19 0x0000003abc2d9a56 in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
#20 0x000000328e60b82d in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#21 0x000000328e621f3e in ?? () from /lib64/libgobject-2.0.so.0
#22 0x000000328e623d09 in g_signal_emit_valist ()
   from /lib64/libgobject-2.0.so.0
#23 0x000000328e624273 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#24 0x0000003abc43441c in gtk_widget_map () from /usr/lib64/libgtk-x11-2.0.so.0
#25 0x0000003abc443dee in ?? () from /usr/lib64/libgtk-x11-2.0.so.0
#26 0x000000328e60b82d in g_closure_invoke () from /lib64/libgobject-2.0.so.0
#27 0x000000328e621f3e in ?? () from /lib64/libgobject-2.0.so.0
#28 0x000000328e623d09 in g_signal_emit_valist ()
   from /lib64/libgobject-2.0.so.0
#29 0x000000328e624273 in g_signal_emit () from /lib64/libgobject-2.0.so.0
#30 0x0000003abc434b9c in gtk_widget_show ()
   from /usr/lib64/libgtk-x11-2.0.so.0
#31 0x0000003abc2b01d7 in gtk_dialog_run () from /usr/lib64/libgtk-x11-2.0.so.0
#32 0x00007f92a62d1f21 in std::ios_base::Init::~Init() ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/fps_gnome.uno.so
#33 0x00007f92a62da4fc in std::ios_base::Init::~Init() ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/fps_gnome.uno.so
#34 0x0000003ac38ef640 in ?? ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/libsfxlx.so
#35 0x0000003ac38ef876 in ?? ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/libsfxlx.so
#36 0x0000003ac38f016d in sfx2::FileDialogHelper::Execute(SfxItemSet*&, String&) () from /usr/lib64/openoffice.org3/program/../basis-link/program/libsfxlx.so
#37 0x0000003ac382095e in ?? ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/libsfxlx.so
#38 0x0000003ac3824b4c in ?? ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/libsfxlx.so
#39 0x0000003ac37c9899 in ?? ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/libsfxlx.so
#40 0x0000003ac388da53 in ?? ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/libsfxlx.so
#41 0x0000003ac3883230 in ?? ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/libsfxlx.so
#42 0x0000003ac38ae2e5 in ?? ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/libsfxlx.so
#43 0x0000003ac38aea69 in ?? ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/libsfxlx.so
#44 0x00007f92adf5fda0 in FontList::~FontList() ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/libfwklx.so
#45 0x0000003ac0e75e86 in Menu::Select() ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so
#46 0x0000003ac0e6fcf5 in ?? ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so
#47 0x0000003ac0ed8869 in ?? ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so
#48 0x00007f92bf8ce7ba in SalDisplay::DispatchInternalEvent() ()
   from /usr/lib64/openoffice.org/basis3.0/program/libvclplug_genlx.so
#49 0x00007f92bfb3c20f in g_hash_table_new ()
   from /usr/lib64/openoffice.org/basis3.0/program/libvclplug_gtklx.so
#50 0x000000328e237bcb in g_main_context_dispatch ()
   from /lib64/libglib-2.0.so.0
#51 0x000000328e23b38d in ?? () from /lib64/libglib-2.0.so.0
#52 0x000000328e23b54b in g_main_context_iteration ()
   from /lib64/libglib-2.0.so.0
#53 0x00007f92bfb3c3a5 in g_hash_table_new ()
   from /usr/lib64/openoffice.org/basis3.0/program/libvclplug_gtklx.so
#54 0x0000003ac0cf013e in Application::Yield(bool) ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so
#55 0x0000003ac0cf01b7 in Application::Execute() ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so
#56 0x0000003ac4a29269 in Config::SetGroup(ByteString const&) ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/libsofficeapp.so
#57 0x0000003ac0cf4754 in ?? ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so
#58 0x0000003ac0cf47f5 in SVMain() ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/libvcllx.so
#59 0x0000003ac4a5be4c in soffice_main ()
   from /usr/lib64/openoffice.org3/program/../basis-link/program/libsofficeapp.so
#60 0x0000000000400f8b in main ()
Comment 6 Horst H. von Brand 2008-12-29 23:14:09 EST
For me, ooimpress hangs just as stated.
Comment 7 Caolan McNamara 2008-12-30 08:48:05 EST
gdk_x11_get_server_time is our man again, this time from gtk_clipboard_set_with_owner which isn't something that OOo does directly, so the hackaround wrapper temporarily in place can't catch it

*** This bug has been marked as a duplicate of bug 477174 ***

Note You need to log in before you can comment on or make changes to this bug.