Bug 47837 - Unable to run CGIs in /home/*/public_html
Unable to run CGIs in /home/*/public_html
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: apache-config (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Florian La Roche
:
: 50362 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-07 21:21 EDT by Need Real Name
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-11 07:43:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-07-07 21:21:48 EDT
Description of Problem: Unable to enable CGI scripts in /home/*/public_html
using existing directions.


How Reproducible:


Steps to Reproduce:
1. Uncomment <Directory /home/*/public_html> lines
2. Add ExecCGI to Options list
3. Uncomment AddHandler cgi-script .cgi
4. Create simple ksh script, test script in /var/www/cgi-bin for
correctness
5. Make sure that full /home/*/public_html path is set to mermissions 755
6. May have forgotten a step here, but see diff comments below where I
diffed operational 6.2 and 7.1 configuration files.

Actual Results:
error_log has Premature end of script headers:, but CGI script file was not
accessed

Expected Results:
Cgi script executed.


Additional Information:

Actually, the configuration was ported from the previous 6.2 install to the
upgraded 7.1. All files and directories in the /home/<user>/public_html
were not changed between 6.2 and 7.1. Diffs between the 6.2 and 7.1
httpd.conf were checked for errors in configuration. The ksh test script
does work in 7.2 /var/www/cgi-bin directory. The 7.2 public_html
configuration is otherwise fully operational.
Comment 1 Michael Schwendt 2001-07-08 01:39:54 EDT
Probably a configuration mistake at your end. Anything logged in
/var/log/httpd/suexec_log? Also have a look at Apache Manual:
FAQ.html#premature-script-headers
Comment 2 Need Real Name 2001-07-11 07:43:21 EDT
After looking at suexec_log, my login and exe file gids did not match, Thanks
Comment 3 Florian La Roche 2001-07-23 08:57:23 EDT
ok, seems to be fixed
Comment 4 Justin Moore 2001-07-31 10:53:34 EDT
*** Bug 50362 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.