Bug 50362 - apache-1.3.19-5 has problems with ExecCGI option
apache-1.3.19-5 has problems with ExecCGI option
Status: CLOSED DUPLICATE of bug 47837
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-07-30 15:39 EDT by Justin Moore
Modified: 2007-04-18 12:35 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-30 20:44:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Apache config (40.10 KB, text/plain)
2001-07-30 15:41 EDT, Justin Moore
no flags Details
Prints environment to stdout (59 bytes, text/plain)
2001-07-30 15:42 EDT, Justin Moore
no flags Details

  None (edit)
Description Justin Moore 2001-07-30 15:39:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.3-12smp i686)

Description of problem:
When I try to run even simple CGIs in a non ScriptAlias'ed directory, I get
"Premature end of script headers".  I have ExecCGI specified for the
directory, and an AddHandler for cgi-scripts.  I've included my httpd.conf
file and a simple cgi that won't work in my directory.  This happened when
I upgraded from 7.0 to 7.1.

How reproducible:
Always

Steps to Reproduce:
1. Configure apache to execute ".cgi" files and set the ExecCGI option for
a user directory.
2. Write a simple CGI to return Content-type header and some text.
3. Go to http://hostname.domain/~user/foo.cgi.

Actual Results:  Apache returns a "403: Forbidden", despite all directories
in the path being mode 755 and the script itself being mode 755.

Expected Results:  It should have printed the environment variables.

Additional info:
Comment 1 Justin Moore 2001-07-30 15:41:16 EDT
Created attachment 25451 [details]
Apache config
Comment 2 Justin Moore 2001-07-30 15:42:43 EDT
Created attachment 25453 [details]
Prints environment to stdout
Comment 3 Michael Schwendt 2001-07-30 20:44:19 EDT
The info here, #bug 47837, fixes your problem most likely.
Comment 4 Justin Moore 2001-07-31 10:53:38 EDT
Turns out to be MIN_GID-blocked by suEXEC.

*** This bug has been marked as a duplicate of 47837 ***

Note You need to log in before you can comment on or make changes to this bug.