Bug 478373 - Modify the section for building release notes locally (git)
Modify the section for building release notes locally (git)
Status: CLOSED WONTFIX
Product: Fedora Documentation
Classification: Fedora
Component: translation-quick-start-guide (Show other bugs)
devel
All Linux
low Severity medium
: ---
: ---
Assigned To: Ruediger Landmann
A S Alam
: Reopened
: 521701 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-28 22:33 EST by Noriko Mizumoto
Modified: 2013-07-02 20:50 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-14 08:53:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noriko Mizumoto 2008-12-28 22:33:58 EST
Hello people,

             For building Fedora-10 release notes locally do the following:

1) Get the source for release-notes and docs-common from git:
   
   1.a) git clone git://git.fedorahosted.org/git/docs/release-notes 

   1.b) git clone git://git.fedorahosted.org/git/fedora-doc-utils docs-common

2) Install 'publican' and 'publican-fedora' packages somehow for your fedora box.

3) Try running the make target: 'make html-<your-locale>' from the base of the release-notes directory.

   example,
   [sshedmak@dhcp6-181 release-notes]$ make html-mr

4) If you see following messages while running make target 'make html-<your-locale>':

   "xml2po command not found" OR
   "xmlto commnad not found"
   
   Install the following rpm somehow (hopefully via yum):

   a) gnome-docs-utils (it provides xml2po utility)
   b) xmlto (helps in parsing XSLT)

5) Try running the make target once again: 'make html-<your-locale>' from the base of the release-notes directory.

6) The build (if successful) creates index.html and other *.html and *.png files within newly created sub-dir called  
   Release_Notes-<yourlocale>. 

7) Open the index.html using firefox from CLI:

   $firefox index.html

   Creation of index.html indicates the integrity of your translations (translations are error-free and  
   won't break package due to erroneous translations).



8) If you guys, encounter any errors while 'make html-<your-locale>' ping me. I would try to dig it...and find some soln  :) 




Regards,
Sandeep

_______________________________________________
doc-i18n-list mailing list
doc-i18n-list@redhat.com
http://post-office.corp.redhat.com/mailman/listinfo/doc-i18n-list
Comment 1 Piotr Drąg 2009-06-12 23:53:31 EDT
IMO it is not needed in *quick* translation guide. Maybe it's worth documenting in DocsProject wiki, as help not only for translators, but for everyone who wants to build any guide with Publican?
Comment 2 Noriko Mizumoto 2009-06-14 21:59:10 EDT
How about to point the sections (3.1 & 3.5) of this book with a little description such as?
http://jfearn.fedorapeople.org/Publican/index.html

To proofread a document created by Publican;

1) First install packages required for build the document.
Please follow "Installing Publican" section of "Publican Users Guide".

2) Build the document in html. Please follow "Building a Book" section of "Publican Users Guide".

Rudi, if this Users Guide may change the location, please advise.
Comment 3 Ruediger Landmann 2009-06-17 03:04:50 EDT
The basic problem is that Sandeep's and Noriko's instructions will not work for the Fedora documentation in the repositories at the moment. The files that translators are contributing through Transifex need a lot of processing before you can build them in Publican. The actual process looks more like this:

---------------------------------

1. Check out a copy of the f11-tx branch of the source:

git clone git://git.fedorahosted.org/docs/user-guide.git
git branch --track f11-tx origin/f11-tx
git checkout f11-tx

The directory that you download should have the following structure:
-- a directory named "en-US", holding the English XML files
-- a directory named "pot", holding the .pot files that correspond to each XML file
-- Publican's Makefile
-- a directory named po, holding a file named LINGUAS, a file named selinux-user-guide.pot that was created by merging together the contents of the pot directory, and the merged po files for various languages including it.po
You can see this structure clearly in, for example, the repo for the Fedora User Guide: http://git.fedorahosted.org/git/?p=docs/user-guide.git;a=tree;h=refs/heads/f11-tx;hb=f11-tx (ignore the es-ES directory for now)

2. add OTHER_LANGS = it-IT to the Publican Makefile if it isn't already there (or add it-IT to this line if OTHER_LANGS is already enabled for languages other than Italian). You can see an example of a well-populated Publican Makefile in the Fedora Installation Guide here: http://git.fedorahosted.org/git/docs/install-guide.git?p=docs/install-guide.git;a=blob_plain;f=Makefile;hb=df349fa845ffbecaa597a4839d83c85228a63bbb

3. install the publican-fedora package (which will also pull in publican itself)

4. In this document's directory (that is, the folder that contains the Makefile and the various directories listed in step 1 above), run "make update-po-it-IT". This will create a directory named it-IT and a set of .po files ready to translate into Italian. (The es-ES directory that you saw in step 1 above was created in this way)

5. run the following  short script to update Publican's po files from the merged po file:

for POTFILE in pot/*.pot; do
       msgmerge po/it.po ${POTFILE} | msgattrib --no-obsolete \
> $'it-IT'/$(basename ${POTFILE} .pot).po
done

For other languages, replace "it.po" with the name of the merged po file for your language, and "it-IT" with the name of the Publican directory for your language

6. run "make html-single-it-IT" to create the document as a single html file. The output will appear in the tmp/it-IT/html-single directory.

On subsequent runs, you will be able to start at step 5.

---------------------------------

Once Fedora's Transifex is updated to version 0.6, most of this will become unnecessary, and instructions like Sandeep's and Noriko's will work. 

When the new version of Transifex is in place, we can also update the "Creating Common Files" section to point to Publican's "Common Content" sections.
Comment 4 Noriko Mizumoto 2009-07-23 21:02:05 EDT
I don't think all translators can follow this instruction.
Comment 5 Ruediger Landmann 2009-07-23 21:08:26 EDT
At the moment, building test docs in Publican from po files submitted through
Transifex is a long, complicated, and error-prone process. 

Furthermore, with both Publican and Transifex moving to new versions soon,
anything that we wrote about this in the TQSG will be irrelevant in the near
future.

For now, if translators want a document for proof-reading, ask on the
fedora-docs-list or in #fedora-docs and someone will help you. 

Please re-open this bug when Publican 1.0 is released *and* Fedora's Transifex
instance has been upgraded to version 0.6.
Comment 6 Noriko Mizumoto 2009-09-07 19:10:52 EDT
*** Bug 521701 has been marked as a duplicate of this bug. ***
Comment 7 Paul W. Frields 2010-03-06 12:54:34 EST
Reopening.  Fedora's Transifex 0.7.4 is about to go to production, and Publican 1.5 (?) is out now.
Comment 8 Paul W. Frields 2010-03-06 14:42:14 EST
Once the infrastructure freeze ends (around 2010-03-10) the new Transifex should be able to go into production, at which point one of the translator leaders can check the series of steps and use them to make an appropriate update of the docs.
Comment 9 Noriko Mizumoto 2010-04-21 00:56:20 EDT
Rudi, thank you for taking this task!
Comment 10 Piotr Drąg 2010-12-14 08:53:47 EST
With Publican 2.0 building and publishing is easier and documented in appropriate documents. There is no need to keep this information also in TQSG.

Note You need to log in before you can comment on or make changes to this bug.