Bug 478401 - corosync ignores mcastport in corosync.conf and uses 7445
corosync ignores mcastport in corosync.conf and uses 7445
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: corosync (Show other bugs)
10
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Dake
Fedora Extras Quality Assurance
:
: 478890 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-29 10:04 EST by Alan Conway
Modified: 2016-04-26 09:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-08 19:26:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
configuration file (441 bytes, application/octet-stream)
2008-12-29 10:04 EST, Alan Conway
no flags Details

  None (edit)
Description Alan Conway 2008-12-29 10:04:20 EST
Description of problem:

I've got mcastport: 5405 in both corosync.conf (attached) but according to strace corosync is using port 7445:

[pid  4977] bind(4, {sa_family=AF_INET, sin_port=htons(7445), sin_addr=inet_addr("226.94.1.1")}, 16) = 0

This is confirmed by changing firewall settings: corosync works if I allow udp 7445 but if I allow udp 5405 it goes into a loop repeating this in the log file:

Dec 29  9:59:49.265860 [TOTEM] entering GATHER state from 3.
Dec 29  9:59:51.094313 [TOTEM] The consensus timeout expired.
Comment 1 Alan Conway 2008-12-29 10:04:53 EST
Created attachment 327924 [details]
configuration file
Comment 2 Steven Dake 2008-12-31 03:40:35 EST
verified with trunk of corosync.  I'll sort it out in the next revision into fedora.

Thanks for the bug report.

Regards
-steve
Comment 3 Steven Dake 2008-12-31 03:41:31 EST
also please note it isn't ignoring the setting.  Instead it has wrong byte order for the port number (7445 is actually 5405 if you endian swap).
Comment 4 Ted Ross 2009-01-06 10:24:10 EST
*** Bug 478890 has been marked as a duplicate of this bug. ***
Comment 5 Steven Dake 2009-05-08 19:26:01 EDT
I believe this is fixed in latest revision of tree.

Note You need to log in before you can comment on or make changes to this bug.