Bug 478890 - Can't attach a client to clustered broker on Fedora 10
Can't attach a client to clustered broker on Fedora 10
Status: CLOSED DUPLICATE of bug 478401
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
1.1
All Linux
low Severity medium
: ---
: ---
Assigned To: Alan Conway
Frantisek Reznicek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-05 16:12 EST by Ted Ross
Modified: 2015-11-15 19:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-06 10:24:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ted Ross 2009-01-05 16:12:57 EST
Tried to run a cluster-of-one-broker on Fedora 10.  Client sessions cannot be established with the broker.

Here are the installed RPMS of interest:

openais-0.91-2.fc10.i386
openais-devel-0.91-2.fc10.i386
cman-2.99.12-2.fc10.i386
cmanlib-2.99.12-2.fc10.i386
qpidd-0.4.728142-1.fc10.i386
qpidd-cluster-0.4.728142-1.fc10.i386


The broker trace that occurs at connection setup:

2009-jan-05 16:01:17 debug RECV [127.0.0.1:56069] INIT(0-10)
2009-jan-05 16:01:17 warning SASL: No Authentication Performed
2009-jan-05 16:01:17 debug 192.168.122.1:28204(INIT) new connection: 192.168.122.1:28204-0x9fedfc0(local)
2009-jan-05 16:01:17 trace 192.168.122.1:28204-0x9fedfc0(local) write idle.
2009-jan-05 16:01:17 trace SENT 127.0.0.1:56069 INIT(0-10)
2009-jan-05 16:01:17 trace SENT [127.0.0.1:56069]: Frame[BEbe; channel=0; {ConnectionStartBody: server-properties={qpid.federation_tag:V2:36:str16(b9650cbd-92c4-438b-bf2a-4c3cdc1ff5a0)}; mechanisms=str16{V2:9:str16(ANONYMOUS)}; locales=str16{V2:5:str16(en_US)}; }]
2009-jan-05 16:01:17 trace 192.168.122.1:28204-0x9fedfc0(local) write idle.
2009-jan-05 16:01:17 trace 192.168.122.1:28204-0x9fedfc0(local) write idle.
2009-jan-05 16:01:17 trace RECVB [127.0.0.1:56069]: 52 bytes
2009-jan-05 16:01:17 trace  MCAST held: [event 192.168.122.1:28204-0x9fedfc0 data 52 bytes]


This happened with both the Python and C++ clients, with auth enabled and disabled on the broker.
Comment 1 Alan Conway 2009-01-06 10:16:07 EST
I'm developing on f10 now and things appear to function correctly.   Can you try this with the firewall off: 

 system service iptables off

There is a bug in the f10 corosync package (https://bugzilla.redhat.com/show_bug.cgi?id=478401 ) that is causing it to use the wrong port for multicast - it's using the endian swap of the configured port. So if your firewall only allows the configured port corosync won't work.
Comment 2 Ted Ross 2009-01-06 10:24:09 EST
Alan,

Thanks.  That solves the problem.

*** This bug has been marked as a duplicate of bug 478401 ***

Note You need to log in before you can comment on or make changes to this bug.