Bug 478686 - NetworkManager supplicant connection state constantly changing when system is not idle
NetworkManager supplicant connection state constantly changing when system is...
Status: CLOSED DUPLICATE of bug 493490
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 490493 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-03 11:41 EST by Wade Nelson
Modified: 2010-07-01 14:15 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-11-10 19:57:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Example of described behaviour (/var/log/messages) (9.18 KB, text/plain)
2009-01-03 11:41 EST, Wade Nelson
no flags Details

  None (edit)
Description Wade Nelson 2009-01-03 11:41:23 EST
Created attachment 328108 [details]
Example of described behaviour (/var/log/messages)

Description of problem:
Using NM on F10 with ipw2200 driver and WPA, NM reports the supplicant connection state constantly changing in /var/log/messages.  This does not happen if the system is idle.


Version-Release number of selected component (if applicable):
Name       : NetworkManager
Arch       : i386
Epoch      : 1
Version    : 0.7.0
Release    : 0.12.svn4326.fc10


How reproducible:
Always.

Steps to Reproduce:
1. Use ipw2200-based wifi card and WPA
2. Connect to AP
3. Do something (anything) with the system.  In the attached logs, actions like running Firefox or AstroMenace were performed at the time the logs start to get spammed.
  
Actual results:
NM should behave.

Expected results:
NM spams /var/log/messages with "supplicant connection state" change messages.

Additional info:
There is no actual interruption in the wifi connection that I can see, just messages claiming that there is.

This may be a kernel/ipw2200 bug, but I couldn't reproduce it by disabling NM and using wpa_supplicant+dhclient to connect.
Comment 1 Dan Williams 2009-02-05 13:54:48 EST
It's normal that when NM is running, it will ask the supplicant to scan.  You can reproduce this issue by using the wpa_supplicant control interface and issuing the "SCAN" command (just like NM does) which will trigger a state change to "scanning" and then back to "completed".  If the issue is really that it's pointless to log the state changes, then we can change the title of the bug to something like "Make NM's log output more fine-grained".
Comment 2 Wade Nelson 2009-02-07 19:37:34 EST
I think cleaning up NM's log output might be a good idea... I've got 400 lines related to NM between Feb 1 and Feb 5.

Maybe even give it it's own log file if it wants to be that verbose.
Comment 3 Dan Williams 2009-02-12 19:09:30 EST
Yeah; though the cron we ship doesn't easily allow for other packages to modify the syslog config.  Debian for example has something like "/etc/rsyslog.d" where something like NM could drop a syslog rule into to redirect NM syslog output to a separate file.
Comment 4 James M. Leddy 2009-08-05 11:22:52 EDT
(In reply to comment #3)
> Yeah; though the cron we ship doesn't easily allow for other packages to modify
> the syslog config.  Debian for example has something like "/etc/rsyslog.d"
> where something like NM could drop a syslog rule into to redirect NM syslog
> output to a separate file.  

Hi Dan,

This seems to be the same as bug 490493, and I'm experiencing this on Fedora 11 as well.  I'm not so worried about supplicant scanning in the background, but I am concerted that each of these messages begins with 'completed -> disconnected' followed by 'disconnected -> scanning'.  It would appear that we need to disconnect with APs before scanning.
Comment 5 Dan Williams 2009-10-15 00:17:20 EDT
(In reply to comment #4)
> (In reply to comment #3)
> > Yeah; though the cron we ship doesn't easily allow for other packages to modify
> > the syslog config.  Debian for example has something like "/etc/rsyslog.d"
> > where something like NM could drop a syslog rule into to redirect NM syslog
> > output to a separate file.  
> 
> Hi Dan,
> 
> This seems to be the same as bug 490493, and I'm experiencing this on Fedora 11
> as well.  I'm not so worried about supplicant scanning in the background, but I
> am concerted that each of these messages begins with 'completed ->
> disconnected' followed by 'disconnected -> scanning'.  It would appear that we
> need to disconnect with APs before scanning.  

Seems like the driver is sending disconnect events; does this still happen with current kernels?  What version are you running where you see the problem?

My ipw2200 is currently doing something else, but when that's done I can test this out.  My configuration is F12 beta, ipw2200, and a WPA AP.  If the driver is indeed sending a disconnect before scanning, that would be wrong and a driver bug.
Comment 6 Dan Williams 2009-10-15 01:18:35 EDT
*** Bug 490493 has been marked as a duplicate of this bug. ***
Comment 7 Dan Williams 2009-11-10 19:57:43 EST
I haven't seen spurious disconnects in F12 Gold on an ipw2200 to a WPA-PSK router...  If you still get them, please file a new bug for it so we can track it there.  I'm duping this bug to one about making logging more selective.

*** This bug has been marked as a duplicate of bug 493490 ***
Comment 8 Renich Bon Ciric 2010-07-01 14:15:58 EDT
I'm experiencing this all the time in Fedora 13

Note You need to log in before you can comment on or make changes to this bug.