Bug 493490 - [enh] more selective logging behavior
[enh] more selective logging behavior
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
12
All Linux
low Severity low
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
: Triaged
: 478686 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-01 18:41 EDT by Tomislav Vujec
Modified: 2010-04-13 19:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-04-13 19:16:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Proposed patch to clean up debug messages from default syslog (different from upstream patch!). (60.39 KB, text/plain)
2009-04-01 18:41 EDT, Tomislav Vujec
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 577663 None None None Never

  None (edit)
Description Tomislav Vujec 2009-04-01 18:41:33 EDT
Created attachment 337678 [details]
Proposed patch to clean up debug messages from default syslog (different from upstream patch!).

While it is entirely possible to disable log spew from NetworkManager by
re-configuring syslog, its treatment of the log levels is completely arbitrary.
I prepared a patch to move most of the info messages to debug level, and left
(or added) only a few, signaling daemon startup and shutdown, as well as up and
down events on the network and vpn devices.
Note:
Attached patch applies to fedora cvs checkout of the most recent rawhide package, upstream patch (attached to gnome bug) applies to git head.
Comment 1 Niels Haase 2009-05-07 18:04:18 EDT
This bug has been triaged

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 2 Bug Zapper 2009-06-09 09:03:06 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Dan Williams 2009-11-10 19:57:43 EST
*** Bug 478686 has been marked as a duplicate of this bug. ***
Comment 4 Dan Williams 2010-04-13 19:16:38 EDT
We now have much finer-grained logging as of NetworkManager-0.8.0-5.git20100408

Note You need to log in before you can comment on or make changes to this bug.