Bug 478737 - portaudio-19-6 breaks compatibility with some apps.
portaudio-19-6 breaks compatibility with some apps.
Status: CLOSED DUPLICATE of bug 478311
Product: Fedora
Classification: Fedora
Component: portaudio (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-04 08:22 EST by Felix Kaechele
Modified: 2009-01-06 15:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-06 15:26:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Felix Kaechele 2009-01-04 08:22:35 EST
Description of problem:
Some portaudio apps don't work anymore since update to portaudio-19-6

Version-Release number of selected component (if applicable):
portaudio-19-6.fc10.x86_64

How reproducible:
Run an incompatible (?) app and get an error message. Examples are performous or ultrastardx.
  
Actual results:
Program hangs (only killable with kill -9) with error message:
Expression 'snd_pcm_start( stream->capture.pcm )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 2082
Expression 'AlsaStart( stream, 0 )' failed in 'src/hostapi/alsa/pa_linux_alsa.c', line: 3272

Expected results:
Program runs fine.

Additional info:
portaudio-19-5 runs fine
Comment 1 Kevin Kofler 2009-01-06 15:23:38 EST
Looks like the dreaded alsa-plugins-pulseaudio capture bug (which is triggered by the PortAudio update because it now finally supports PulseAudio).

See https://bugzilla.redhat.com/show_bug.cgi?id=478311 and https://admin.fedoraproject.org/updates/F10/FEDORA-2008-11952 .
Comment 2 Kevin Kofler 2009-01-06 15:26:29 EST
The submitter confirmed on IRC that the alsa-plugins-pulseaudio update from updates-testing fixes this. Closing as a duplicate.

*** This bug has been marked as a duplicate of bug 478311 ***

Note You need to log in before you can comment on or make changes to this bug.