Bug 478776 - Netmask horribly foobared, set to the gateway address in graphical configuration
Netmask horribly foobared, set to the gateway address in graphical configuration
Status: CLOSED DUPLICATE of bug 469434
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-04 18:15 EST by David Tonhofer
Modified: 2009-01-05 04:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-05 04:11:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Config window showing the bad netmask. It won't go away! (56.16 KB, image/png)
2009-01-04 18:17 EST, David Tonhofer
no flags Details

  None (edit)
Description David Tonhofer 2009-01-04 18:15:46 EST
Description of problem:

I want to configure the network through the gnome graphical config, which is apparently a frontend to system-config network.

eth0 shall not be under control of Network Manager, we do not get configuration from DHCP but set it statically:

IP = 192.168.1.40
NM = 255.255.255.0
GW = 192.168.1.254

Very classical.

Unfortunately, the configurator insists on resetting the netmask to 192.168.1.254, there is no way to set it to anything reasonable (see screenshot).

Activation of eth0 shows messed-up routes and the netmask 192.0.0.0 configured. No network connection, of course.

[root@gefjun ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:23:54:15:18:31  
          inet addr:192.168.1.40  Bcast:255.255.255.255  Mask:192.0.0.0
          inet6 addr: fe80::223:54ff:fe15:1831/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:236 errors:0 dropped:0 overruns:0 frame:0
          TX packets:306 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:240200 (234.5 KiB)  TX bytes:52162 (50.9 KiB)
          Interrupt:22 Base address:0x2000 

Workaround is to manually correct the netmask in /etc/sysconfig/network-scripts/ifcfg-eth0.

Version-Release number of selected component (if applicable):

system-config-network-1.5.93-2.fc10.noarch, om a fully updated F10 system.

How reproducible:

Unsure as yet.
Comment 1 David Tonhofer 2009-01-04 18:17:20 EST
Created attachment 328160 [details]
Config window showing the bad netmask. It won't go away!
Comment 2 David Tonhofer 2009-01-04 18:26:27 EST
This seems to be a duplicate of bug#469434
Comment 3 David Tonhofer 2009-01-04 18:28:43 EST
Also a duplicate of bug#475419 ... didn't find those when looking through system-config-network bugs for F10 though.
Comment 4 Jiri Moskovcak 2009-01-05 04:11:32 EST

*** This bug has been marked as a duplicate of bug 469434 ***

Note You need to log in before you can comment on or make changes to this bug.