Bug 478811 - Impossible to disable the graphical ask-for-passphrase thing
Impossible to disable the graphical ask-for-passphrase thing
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomáš Bžatek
Fedora Extras Quality Assurance
:
: 488165 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-05 03:06 EST by David Nečas
Modified: 2015-03-03 17:33 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-18 02:29:40 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nečas 2009-01-05 03:06:59 EST
Description of problem:
It is not possible to disable the GUI dialog that pops up when I run ssh in terminal and need to enter a passphrase (and that prevents from entering the passphrase on the terminal -- where, unlike in the dialog, there is visible causal link between me running a command and this command asking for a passphrase).

Version-Release number of selected component (if applicable):
gnome-keyring-2.24.1-1.fc10

How reproducible:
Always

Steps to Reproduce:
1. Unset SSH_ASKPASS and DISPLAY (ssh(1)).
2. For a good measure uninstall openssh-askpass.
3. Install gconf-editor and find the well-hidden key /apps/gnome-keyring/daemon-components/ssh and disable it.
4. Notice that it says that it only takes effect when the daemon is started and restart Gnome.
5. Try to locate gnome-keyring-daemon manual page or other documentation regarding configuring it, find none.
6. Run ssh somewhere-where-I-authentize-using-key-and-passphrase
  
Actual results:
A GUI dialog pops up.

Expected results:
I am asked for passphrase in the terminal where I ran the ssh command.

Additional info:
I can, of course, unset SSH_AUTH_SOCK or just killall gnome-keyring-daemon or something along these lines.  But this is not user-level configuration.
Comment 1 Charles R. Anderson 2009-03-06 20:45:59 EST
*** Bug 488165 has been marked as a duplicate of this bug. ***
Comment 2 Bug Zapper 2009-11-18 05:39:37 EST
This message is a reminder that Fedora 10 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 10.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '10'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 10's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 10 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 3 Bug Zapper 2009-12-18 02:29:40 EST
Fedora 10 changed to end-of-life (EOL) status on 2009-12-17. Fedora 10 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.