Bug 478851 - barry cannot connect to Blackberry Bold: -1, error sending control message: Operation not permitted): Probe: GetConfiguration failed
barry cannot connect to Blackberry Bold: -1, error sending control message: O...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: barry (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Christopher D. Stover
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-05 11:48 EST by Nick Boldt
Modified: 2009-12-30 23:07 EST (History)
7 users (show)

See Also:
Fixed In Version: 0.15-0.7.20090630git.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-03 15:32:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Error message from barry on Fedora 11 Preview, x86_64, Blackberry 8830 (10.21 KB, image/png)
2009-04-30 21:30 EDT, Bob Cochran
no flags Details
Error message on Barry Backup in Fedora 12 (release version) (9.29 KB, image/png)
2009-12-04 12:09 EST, Bob Cochran
no flags Details

  None (edit)
Description Nick Boldt 2009-01-05 11:48:11 EST
Description of problem:

Cannot connect my Fedora 10 box to my Blackberry Bold 9000 over USB. I didn't try connecting over bluetooth.

Version-Release number of selected component (if applicable):

barry-0.14-4.fc10 and 
barry-0.14-6.fc11

How reproducible:

Happens every time.

Steps to Reproduce:

1. install barry
2. plug in device - Thunar shows it mounted and available to browse
3. run barrybackup (from console or gnome menu item "backup")
4. get this error:

> (-1, error sending control message: Operation 
> not permitted): Probe: GetConfiguration failed
  
Actual results:

barry won't connect. nothing useful happens.

Expected results:

Never having used barry, I'm not really sure what should have happened...

Additional info:

I sent my concerns to Petr Machata, who responded thus:

> I did a quick google, and it might be related to permissions of USB
> device file.  I think ConsoleKit should handle this for you, but I'm 
> not quite sure how all the desktop magic works.  You might try to 
> sidestep the issue thus:
>  - look at the output of /sbin/lsusb, which bus and device your
> blackberry is connected to
>  - under root, chmod a+rwx /dev/bus/usb/<bus>/<device>
>
> Anyway, I'd open a bug in Red Hat bugzilla (component barry).

I'll try this approach later, but I wanted to report the issue in case it at least warranted a wiki entry or README somewhere.
Comment 1 Nick Boldt 2009-01-05 12:00:19 EST
chmod trick worked. As did simply running barrybackup as root. But since barrybackup is added to the user's Gnome menu under Accessories, shouldn't it at least be wrapped with ConsoleKit so the user's prompted to run it as root?
Comment 2 Christopher D. Stover 2009-01-09 15:11:18 EST
Thanks for the bug report Nick.  Upstream is aware of this issue.  However when I tried Petr's trick I got this:
Usb::Error caught in main:
(-2, error submitting URB: No such file or directory): Error in usb_bulk_read

Have you seen this on your end?  I'm not familiar with ConsoleKit other than quickly looking at their website, but I'll pass it upstream and hopefully we can get it fixed soon.
Comment 3 Nick Boldt 2009-01-09 16:23:39 EST
I haven't see the error you did. Running after chmod'ing (as myself or as root) worked as expected.

Maybe you're missing one of the deps that are stated as requirements (but not resolved by yum when installing?):

http://www.netdirect.ca/software/packages/barry/dependencies.php

Or maybe you have a different version of libopensync? The docs state I should be using 0.22, but Fedora 10 (ie., yum) installed 0.36 for me. Seems there's another packaging requirement problem there too -- shouldn't yum know to backlevel to 0.22 instead of installing the latest, if the latest isn't supported?

I'm still trying to figure out how to do all the other touted things I can supposedly do with barry. Perhaps because the tools aren't all named "barry*", I've only found the backup tool. How does one sync or install apps?
Comment 4 Nick Boldt 2009-01-09 16:28:06 EST
BTW, running this seems to show that barry 0.14.4-fc10 does NOT actually declare its dependency on libopensync (or maybe I'm doing this wrong?)

$ yum deplist barry | grep sync
$ yum deplist barry-libs | grep sync
Comment 5 Christopher D. Stover 2009-01-09 17:00:17 EST
Nope, I double checked and I have all the required deps.

As for libopensync, I've filed a bug against it: https://bugzilla.redhat.com/show_bug.cgi?id=474070.  The version of libopensync Fedora is using is not the stable version and barry is incompatible with it.  Therefore, if you're using anything newer than F8, you will be unable to sync.

To my knowledge, there's no program at the moment that will allow you to install things.  My main reason for installing and packaging barry was the ability to charge my phone.  When you plug in your phone, it automatically runs bcharge.  However, you are able to tether your phone if you use your phone for the internet.
Comment 6 Scott Glaser 2009-04-18 23:27:19 EDT
I have the same issue with my Blackberry 8330 when using the usb interface.  

(-1, error sending control message: Operation not permitted): Probe: GetConfiguration failed

I have tried the all the workarounds listed in this bug with no change in status:

chmod a+rwx /dev/bus/usb/<bus>/<device>

It still displays the same message, I have also check all the dependencies listed on page http://www.netdirect.ca/software/packages/barry/dependencies.php
and have them installed.

If you need further information let me know.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 7 Bob Cochran 2009-04-30 21:30:06 EDT
Created attachment 342029 [details]
Error message from barry on Fedora 11 Preview, x86_64, Blackberry 8830

I connected my Blackberry 8830 World Edition (provided by Sprint) while it was turned on and running, to my laptop over USB. Then I clicked Applications > Acessories > backup and got the error message shown in the png.
Comment 8 Bob Cochran 2009-04-30 21:33:56 EDT
Output from the operation described in comment #7, in /var/log/messages:

Apr 30 21:18:03 deafeng3 kernel: usb 6-1: new full speed USB device using uhci_hcd and address 2
Apr 30 21:18:03 deafeng3 kernel: usb 6-1: New USB device found, idVendor=0fca, idProduct=0006
Apr 30 21:18:03 deafeng3 kernel: usb 6-1: New USB device strings: Mfr=1, Product=4, SerialNumber=3
Apr 30 21:18:03 deafeng3 kernel: usb 6-1: Product: RIM Mass Storage Device
Apr 30 21:18:03 deafeng3 kernel: usb 6-1: Manufacturer: Research In Motion
Apr 30 21:18:03 deafeng3 kernel: usb 6-1: SerialNumber: 920DFBC8567158EE53A4FBEB560AB2B3F6045F66
Apr 30 21:18:03 deafeng3 kernel: usb 6-1: configuration #1 chosen from 1 choice
Apr 30 21:18:03 deafeng3 kernel: usb 6-1: USB disconnect, address 2
Apr 30 21:18:03 deafeng3 kernel: usb 6-1: new full speed USB device using uhci_hcd and address 3
Apr 30 21:18:04 deafeng3 kernel: usb 6-1: New USB device found, idVendor=0fca, idProduct=0004
Apr 30 21:18:04 deafeng3 kernel: usb 6-1: New USB device strings: Mfr=1, Product=5, SerialNumber=3
Apr 30 21:18:04 deafeng3 kernel: usb 6-1: Product: RIM Composite Device
Apr 30 21:18:04 deafeng3 kernel: usb 6-1: Manufacturer: Research In Motion
Apr 30 21:18:04 deafeng3 kernel: usb 6-1: SerialNumber: 920DFBC8567158EE53A4FBEB560AB2B3F6045F66
Apr 30 21:18:04 deafeng3 kernel: usb 6-1: configuration #1 chosen from 1 choice
Apr 30 21:18:04 deafeng3 kernel: Initializing USB Mass Storage driver...
Apr 30 21:18:04 deafeng3 kernel: scsi6 : SCSI emulation for USB Mass Storage devices
Apr 30 21:18:04 deafeng3 kernel: usbcore: registered new interface driver usb-storage
Apr 30 21:18:04 deafeng3 kernel: USB Mass Storage support registered.
Apr 30 21:18:09 deafeng3 kernel: scsi 6:0:0:0: Direct-Access     RIM      BlackBerry SD    0001 PQ: 0 ANSI: 4 CCS
Apr 30 21:18:09 deafeng3 kernel: sd 6:0:0:0: [sdb] Attached SCSI removable disk
Apr 30 21:18:09 deafeng3 kernel: sd 6:0:0:0: Attached scsi generic sg2 type 0
Apr 30 21:21:08 deafeng3 kernel: usb 6-1: USB disconnect, address 3
Apr 30 21:21:35 deafeng3 kernel: usb 6-1: new full speed USB device using uhci_hcd and address 4
Apr 30 21:21:35 deafeng3 kernel: usb 6-1: New USB device found, idVendor=0fca, idProduct=0006
Apr 30 21:21:35 deafeng3 kernel: usb 6-1: New USB device strings: Mfr=1, Product=4, SerialNumber=3
Apr 30 21:21:35 deafeng3 kernel: usb 6-1: Product: RIM Mass Storage Device
Apr 30 21:21:35 deafeng3 kernel: usb 6-1: Manufacturer: Research In Motion
Apr 30 21:21:35 deafeng3 kernel: usb 6-1: SerialNumber: 920DFBC8567158EE53A4FBEB560AB2B3F6045F66
Apr 30 21:21:35 deafeng3 kernel: usb 6-1: configuration #1 chosen from 1 choice
Apr 30 21:21:35 deafeng3 kernel: scsi7 : SCSI emulation for USB Mass Storage devices
Apr 30 21:21:35 deafeng3 kernel: usb 6-1: usbfs: interface 0 claimed by usb-storage while 'bcharge' sets config #1
Apr 30 21:21:35 deafeng3 kernel: usb 6-1: USB disconnect, address 4
Apr 30 21:21:36 deafeng3 kernel: usb 6-1: new full speed USB device using uhci_hcd and address 5
Apr 30 21:21:36 deafeng3 kernel: usb 6-1: New USB device found, idVendor=0fca, idProduct=0004
Apr 30 21:21:36 deafeng3 kernel: usb 6-1: New USB device strings: Mfr=1, Product=5, SerialNumber=3
Apr 30 21:21:36 deafeng3 kernel: usb 6-1: Product: RIM Composite Device
Apr 30 21:21:36 deafeng3 kernel: usb 6-1: Manufacturer: Research In Motion
Apr 30 21:21:36 deafeng3 kernel: usb 6-1: SerialNumber: 920DFBC8567158EE53A4FBEB560AB2B3F6045F66
Apr 30 21:21:36 deafeng3 kernel: usb 6-1: configuration #1 chosen from 1 choice
Apr 30 21:21:36 deafeng3 kernel: scsi8 : SCSI emulation for USB Mass Storage devices
Apr 30 21:21:41 deafeng3 kernel: scsi 8:0:0:0: Direct-Access     RIM      BlackBerry SD    0001 PQ: 0 ANSI: 4 CCS
Apr 30 21:21:41 deafeng3 kernel: sd 8:0:0:0: [sdb] Attached SCSI removable disk
Apr 30 21:21:41 deafeng3 kernel: sd 8:0:0:0: Attached scsi generic sg2 type 0
Apr 30 21:22:29 deafeng3 kernel: usb 6-1: USB disconnect, address 5
Comment 9 Bob Cochran 2009-05-02 10:25:34 EDT
I installed, on a Fedora 11 Preview on x86_64 laptop:

libopensync
libtar-devel

then I ran

/sbin/lsusb

to find out which bus and device my Blackberry was assigned to. Turned out to be bus 006 device 003

then I ran the trick mentioned in the problem description, where

chmod a+rwx /dev/bus/usb/<bus>/<device> 

was modified to

chmod a+rwx /dev/bus/usb/006/003

and I tried using Barry again with the goal of performing a backup. It worked like a charm!

So it looks like changing the barry package to include libopensync and libtar-devel as dependencies will help.
Comment 10 Christopher D. Stover 2009-05-02 22:42:51 EDT
Thanks Bob.  I'm going to be building a new snapshot of Barry tomorrow hopefully.  I'll be building with the libopensync dependency since Fedora downgraded it.  Please keep your eye out for this and let me know how it works for you.  It should be available on Rawhide in the next couple days.
Comment 11 Bob Cochran 2009-05-03 00:09:47 EDT
It looks like Blackberry devices can get assigned to different /dev/bus/usb/<bus>/<device>. Yesterday, my Blackberry was on /dev/bus/usb/006/003, today it looks like it is on /dev/bus/usb/006/005. The device number changed. This behavior can upset the barry software if the new device doesn't have rwx permissions on it. I went through the chmod routine once more and was able to get today's backup to work.

Here is the output of /sbin/lsusb and the chmod action I took:

# /sbin/lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 006: ID 0c45:63f8 Microdia 
Bus 001 Device 011: ID 045e:0084 Microsoft Corp. Basic Optical Mouse
Bus 001 Device 010: ID 046d:c315 Logitech, Inc. Classic New Touch Keyboard
Bus 001 Device 009: ID 051d:0002 American Power Conversion Uninterruptible Power Supply
Bus 001 Device 012: ID 413c:8153 Dell Computer Corp. 
Bus 001 Device 013: ID 413c:8154 Dell Computer Corp. 
Bus 001 Device 003: ID 413c:2513 Dell Computer Corp. 
Bus 001 Device 007: ID 413c:8149 Dell Computer Corp. 
Bus 001 Device 008: ID 0a5c:4500 Broadcom Corp. 
Bus 001 Device 004: ID 413c:2513 Dell Computer Corp. 
Bus 001 Device 002: ID 0424:2512 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 0a5c:5800 Broadcom Corp. 
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 005: ID 0fca:0004 Research In Motion, Ltd. 
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
# chmod a+rwx /dev/bus/usb/006/005

[barry is able to find the Blackberry device at this point]

[barry is able to back up the Blackberry device at this point]
Comment 12 Bob Cochran 2009-05-15 17:57:05 EDT
Each time you connect a Blackberry to a Fedora 11 system, the 

/dev/bus/usb/[bus]/[device] 

assigned to it has to have permissions freshly assigned through chmod. This means becoming root and doing the chmod as a preprequisite to doing the backup. I presume udev does all the work of creating the device entry, but doesn't assign friendly permissions to it. Perhaps barry can add an appropriate udev rule for me at install time? I'll also ask around on the Fedora-list to see if I can add a rule manually.
Comment 13 Adam Williamson 2009-05-15 19:18:00 EDT
Barry does ship with a /etc/security/console.perms.d/10-blackberry.perms file, with the contents:

<blackberry>=/dev/bb-*
<console> 0660 <blackberry> 0660 root

which suggests that it expects the Blackberry device nodes to be /dev/bb-* ...maybe this needs updating?
Comment 14 Bug Zapper 2009-06-09 06:35:22 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 15 John Ellson 2009-06-19 19:56:54 EDT
Bug still exists in Rawhide - fc12
Comment 16 Fedora Update System 2009-07-01 20:53:05 EDT
barry-0.15-0.7.20090630git.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/barry-0.15-0.7.20090630git.fc9
Comment 17 Fedora Update System 2009-07-01 20:56:26 EDT
barry-0.15-0.7.20090630git.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/barry-0.15-0.7.20090630git.fc10
Comment 18 Fedora Update System 2009-07-01 21:00:05 EDT
barry-0.15-0.7.20090630git.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/barry-0.15-0.7.20090630git.fc11
Comment 19 Bob Cochran 2009-07-01 21:20:28 EDT
barry-0.15-0.6.20090623git.fc11.x86_64, installed on my machine, no longer has an entry on my Gnome applications menu under "Accesories" where it once was. 

Running 'barrybackup' as an ordinary user gets an error:

[rlc@deafeng3 ~]$ barrybackup
Usb::Error caught in main:
(-1, error sending control message: Operation not permitted): Probe: GetConfiguration failed

(barrybackup:7936): Gdk-CRITICAL **: gdk_x11_atom_to_xatom_for_display: assertion `atom != GDK_NONE' failed

I again had to follow this process as root:

[root@deafeng3 ~]# lsusb
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 010: ID 046d:c315 Logitech, Inc. Classic New Touch Keyboard
Bus 001 Device 011: ID 045e:0084 Microsoft Corp. Basic Optical Mouse
Bus 001 Device 004: ID 413c:2513 Dell Computer Corp. 
Bus 001 Device 006: ID 0c45:63f8 Microdia 
Bus 001 Device 009: ID 051d:0002 American Power Conversion Uninterruptible Power Supply
Bus 001 Device 013: ID 413c:8154 Dell Computer Corp. 
Bus 001 Device 012: ID 413c:8153 Dell Computer Corp. 
Bus 001 Device 008: ID 0a5c:4500 Broadcom Corp. 
Bus 001 Device 007: ID 413c:8149 Dell Computer Corp. 
Bus 001 Device 003: ID 413c:2513 Dell Computer Corp. 
Bus 001 Device 002: ID 0424:2512 Standard Microsystems Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 0a5c:5800 Broadcom Corp. 
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 006 Device 008: ID 0fca:0004 Research In Motion, Ltd. 
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
[root@deafeng3 ~]# chmod a+rwx /dev/bus/usb/006/008


...at which point `barrybackup` worked.

Bob
Comment 20 Christopher D. Stover 2009-07-01 21:32:43 EDT
Thanks Bob.  I temporarily removed the menu entry, but it will reappear in the next update with an icon instead of a blank spot where an icon should be.

The permission issues have also been fixed if the next update.  You're welcome to download the update from testing and give it a karma rating if you like.  Thank you for taking the time to submit the additional info to this bug report.

Chris
Comment 21 Fedora Update System 2009-07-03 15:32:15 EDT
barry-0.15-0.7.20090630git.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Fedora Update System 2009-07-03 15:38:00 EDT
barry-0.15-0.7.20090630git.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 23 Fedora Update System 2009-07-03 15:49:39 EDT
barry-0.15-0.7.20090630git.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 24 Bob Cochran 2009-07-04 18:58:22 EDT
There is a huge improvement with barry-0.15-0.7.20090630git.fc11.x86_64. For the first time, it was able to back up my device just by my opening the appication from the Applications...Accessories graphical menu and clicking the backup button. Two clicks and no fooling with chmod. Well done, thanks! Now I just need to wait for my Blackberry to have a tough day and crash and see if barry can restore the data.

Bob
Comment 25 Bob Cochran 2009-12-04 12:06:44 EST
This problem is now occurring in Fedora 12. I just attempted to do a backup on Fedora 12, and it failed. I'm attaching a screenshot of the error message. I will be happy to reopen this bug under Fedora 12 if desired. Thanks, Bob Cochran
Comment 26 Bob Cochran 2009-12-04 12:09:13 EST
Created attachment 376132 [details]
Error message on Barry Backup in Fedora 12 (release version)
Comment 27 Jeffrey D. Yuille 2009-12-30 23:07:53 EST
As I have been able to Google over this permission issue, I have finally been able to backup my BlackBerry Curve 8310 with the Barry GUI as a root user using chmod. Will this problem be fixed in Fedora 12 anytime soon? Then again, I should be satisfied that I am able to backup my BlackBerry, period.

Note You need to log in before you can comment on or make changes to this bug.