Bug 478993 - When nomachine's nxclient is installed qtnx picks the wrong nxssh and breaks on libcrypto.so.*
Summary: When nomachine's nxclient is installed qtnx picks the wrong nxssh and breaks ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: freenx-client
Version: 10
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 495467 511937 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-01-06 12:08 UTC by Joachim Backes
Modified: 2009-08-10 21:47 UTC (History)
4 users (show)

Fixed In Version: 0.9-10.fc11
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-08-10 21:46:23 UTC
Type: ---


Attachments (Terms of Use)

Description Joachim Backes 2009-01-06 12:08:27 UTC
Description of problem:
I installed freenx-client with yum. Then starting qtnx and configuring it. If trying to connect to the nx server, the corresponing process exits. Logging output:

nxssh: error while loading shared libraries: libcrypto.so.0.9.8: cannot open shared object file: No such file or directory

Indeed, there is no libcrypto.so.0.9.8 in the /lib directory, I only found /lib/libcrypto.so.0.9.8g (part of openssl-0.9.8g-11.fc10.i686).

Version-Release number of selected component (if applicable):
freenx-client-0.9-7.fc10.i386

How reproducible:
each time

Steps to Reproduce:
1.start qtnx and configure it
2.connect to the server
3.
  
Actual results:
connection process exits

Expected results:
connection it done

Additional info:

Comment 1 Norman Gaywood 2009-02-19 04:27:01 UTC
I'm getting this as well. It seems freenx-client contains a /usr/NX/lib/ with the libraries required to start qtnx (including the lib/libcrypto.so.0.9.8 mentioned above) but this directory is not searched.

If I start qtnx with:

export LD_LIBRARY_PATH=/usr/NX/lib; qtnx

I get further.

Comment 2 Joachim Backes 2009-04-18 07:21:23 UTC
(In reply to comment #1)
> I'm getting this as well. It seems freenx-client contains a /usr/NX/lib/ with
> the libraries required to start qtnx (including the lib/libcrypto.so.0.9.8
> mentioned above)

This is not correct: freenx-client does not provide a directory like /usr/NX/lib
nor a lib as lib/libcrypto.so.0.9.8, but you have to install the nx package (beside free-nx) additionally.

After having installed nx, I proceeded.

> 
> If I start qtnx with:
> 
> export LD_LIBRARY_PATH=/usr/NX/lib; qtnx
> 
> I get further.

Comment 3 Jonathan Haskins 2009-05-30 15:04:38 UTC
This and bug 495467 are dups of each other. It's caused by having nxclient from nomachine installed alongside freenx-client.

Comment 4 Axel Thimm 2009-07-25 14:26:16 UTC
*** Bug 495467 has been marked as a duplicate of this bug. ***

Comment 5 Axel Thimm 2009-07-25 14:30:24 UTC
*** Bug 511937 has been marked as a duplicate of this bug. ***

Comment 6 Axel Thimm 2009-07-25 17:34:33 UTC
I'm not sure we can fix this on our side. The nxclient package forces its path, so that its nxssh is picked up which isn't setup correctly wrt to library paths. When nxclient uses it is does setup the environment to find these libraries correctly.

E.g. nxssh from nomachines should either had not been in the $PATH or it should be able to work self-sustained. Both can only be fixed by the package's makers (nomachine).

If anyone has a better idea, please reopen and comment here.

Comment 7 Axel Thimm 2009-07-25 23:04:16 UTC
Actually since nomachine's current package adds its path component to the end of the path, we are lucky and our nxssh is preferred when both are present.

Comment 8 Fedora Update System 2009-07-25 23:05:18 UTC
freenx-client-0.9-10.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/freenx-client-0.9-10.fc10

Comment 9 Fedora Update System 2009-07-25 23:05:36 UTC
freenx-client-0.9-10.fc11 has been submitted as an update for Fedora 11.
http://admin.fedoraproject.org/updates/freenx-client-0.9-10.fc11

Comment 10 Fedora Update System 2009-07-27 21:27:12 UTC
freenx-client-0.9-10.fc11 has been pushed to the Fedora 11 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update freenx-client'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F11/FEDORA-2009-8008

Comment 11 Fedora Update System 2009-07-27 21:33:45 UTC
freenx-client-0.9-10.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update freenx-client'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-8028

Comment 12 Fedora Update System 2009-08-10 21:46:04 UTC
freenx-client-0.9-10.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2009-08-10 21:46:48 UTC
freenx-client-0.9-10.fc11 has been pushed to the Fedora 11 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.