Bug 495467 - Cannot start qtnx (some missing library problem)
Cannot start qtnx (some missing library problem)
Status: CLOSED DUPLICATE of bug 478993
Product: Fedora
Classification: Fedora
Component: freenx-client (Show other bugs)
11
All Linux
low Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-04-13 06:48 EDT by Joachim Backes
Modified: 2009-07-31 13:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-07-25 10:26:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2009-04-13 06:48:42 EDT
Description of problem:

Starting qtnx dies with: 
qtnx
Process started
stderr> nxssh: error while loading shared libraries: libcrypto.so.0.9.8: cannot open shared object file: No such file or directory
Process exited

Then I tried for workaround purposes:
ln -s /usr/lib/libcrypto.so.0.9.8k /usr/lib/libcrypto.so.0.9.8

and started qtnx again:

Process started
stderr> nxssh: error while loading shared libraries: libXcomp.so.3: cannot open shared object file: No such file or directory
Process exited

Then I gave up!

Version-Release number of selected component (if applicable):
freenx-client-0.9-8.fc11.i586

How reproducible:
Each time

Steps to Reproduce:
1.Start qtnx
2.Fillout the username and password field after having configued a session
3.Click the connect button
  
Actual results:
Error msg: missing lib or libs

Expected results:
Connection proceeds

Additional info:

Additionally: Having the same problem in F10!
Comment 1 Joachim Backes 2009-04-14 05:38:10 EDT
Workaround after having installed freenx (and nx);

1. ln -s /lib/libcrypto.so.0.9.8k /lib/libcrypto.so.0.9.8
2. LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/usr/NX/lib
Comment 2 Joachim Backes 2009-04-14 05:39:34 EDT
Sorry, I meant:

1. ln -s /usr/lib/libcrypto.so.0.9.8k /usr/lib/libcrypto.so.0.9.8
Comment 3 Jonathan Haskins 2009-05-30 08:09:33 EDT
Confirmed on my end. Problem still exists in latest rawhide.
Comment 4 Jonathan Haskins 2009-05-30 08:45:06 EDT
This only occurs if you install qtnx alongside the nomachine nxclient WITHOUT installing the fedora nx package. Once the nx package is installed the error goes away. This bug is connected with bug 491599 since depending on fedora's nx package seems to fix the problem.
Comment 5 Bug Zapper 2009-06-09 09:44:41 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 6 Axel Thimm 2009-07-25 10:26:16 EDT
(In reply to comment #0)
> stderr> nxssh: error while loading shared libraries: libcrypto.so.0.9.8: cannot
> open shared object file: No such file or directory
> Process exited

As Jonathan Haskins pointed out in bug #478993 comment #3 this is due to the nomachine nxclient providing an nxssh in the (modified) PATH that requires this library.

Please uninstall nxclient and install nx.

*** This bug has been marked as a duplicate of bug 478993 ***

Note You need to log in before you can comment on or make changes to this bug.