Bug 479089 - system-config-network does not require needed gnome-python2-bonobo
system-config-network does not require needed gnome-python2-bonobo
Status: CLOSED DUPLICATE of bug 472154
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
10
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-06 19:55 EST by Rick Wagner
Modified: 2009-01-07 09:16 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-07 09:16:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick Wagner 2009-01-06 19:55:53 EST
Description of problem:
I did a KDE only installation of F10.  I wanted to use S-C-N in place of NetworkManager.  yum installed S-C-N, ran it, set the settings, then did a "File->Save".  There was a message on the console (started S-C-N from a command line), something about missing bonobo interface.  Exiting S-C-N prompted me to save my changes; I clicked 'Yes', but the app did not close.  Tried to exit again, and got the same message.  Exited without saving, then restarted; my changes were not set.

Yum installed gnome-python2-bonobo, reran S-C-N and worked properly.

It appears S-C-N package does not have necessary requires for gnome-python2-bonobo.

Version-Release number of selected component (if applicable):
system-config-network.noarch         1.5.93-2.fc10                       
system-config-network-tui.noarch     1.5.93-2.fc10
gnome-python2-bonobo.i386            2.22.3-1.fc10

Steps to Reproduce:
1. Install KDE only config (i.e. no gnome-python2-bonobo)
2. Run S-C-N, make changes; attempt to save

Actual results:
Changes do not get saved

Expected results:
Changes should be saved

Additional info:

Just a guess, but a simple test on a working system would be to yum erase gnome-python2-bonobo; it is likely that you would not get a dependency failure though you should.
Comment 1 Jiri Moskovcak 2009-01-07 09:16:47 EST

*** This bug has been marked as a duplicate of bug 472154 ***

Note You need to log in before you can comment on or make changes to this bug.