Bug 479144 - Please build libwvstreams --with-dbus
Please build libwvstreams --with-dbus
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libwvstreams (Show other bugs)
11
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ondrej Vasik
Fedora Extras Quality Assurance
: Reopened
Depends On: 508486
Blocks: 456684
  Show dependency treegraph
 
Reported: 2009-01-07 10:39 EST by Konstantin Ryabitsev
Modified: 2009-07-03 22:45 EDT (History)
2 users (show)

See Also:
Fixed In Version: libwvstreams-4.6-3.fc12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-28 04:05:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Konstantin Ryabitsev 2009-01-07 10:39:58 EST
I'm trying to get pathfinder (http://code.google.com/p/pathfinder-pki/) included in Fedora, but it requires dbus components of libwvstreams. Could you please build libwvstreams --with-dbus?
Comment 1 Ondrej Vasik 2009-01-08 07:38:19 EST
Built as libwvstreams-4.5.1-1.fc11 , closing RAWHIDE.
Comment 2 Konstantin Ryabitsev 2009-01-08 08:45:07 EST
Sweet, thanks!
Comment 3 Konstantin Ryabitsev 2009-01-09 10:00:16 EST
A small problem -- the .%{_libdir}/pkgconfig/libwvdbus.pc is still removed in %install in 4.5.1-1.fc11, so it never shows up in -devel package.
Comment 4 Ondrej Vasik 2009-01-09 11:12:44 EST
Ooops, thanks for info ... fixed and built as libwvstreams-4.5.1-2.fc11 , closing RAWHIDE again... hopefully last time ;).
Comment 5 Konstantin Ryabitsev 2009-01-11 18:32:46 EST
This is actually more hairy than it seemed at first. Currently, libwvstreams is looking for libdbus-1.a when checking for dbus support in configure, and when that fails on Fedora (no .a, only .so), it automatically turns off dbus support. 

I tried to make it work with a .so, but there seem to be some weird clashes between their bundled support for dbus marshalling (from dbus-0.60?) and the .so provided by the dbus package in Fedora.

I posted to the libwvstreams-devel list asking about possible solutions. Until one is found, I suggest we roll back to the way things were before this bug was opened -- just so we don't include libwvdbus.pc without actually providing a libwvdbus.so.

(BTW, I'm a fedora maintainer -- if you would like to co-maintain this package, I can help out)
Comment 6 Ondrej Vasik 2009-01-12 06:28:53 EST
I guess it's only rawhide change and that dbus support is planned, so I would keep it as it is at the moment ... hopefully we will get answer from wvstreams-devel soon - otherwise I'll remove those dbus changes before F11.

There are no opened problems with libwvstreams at the moment, so I guess co-maintaining is not necessary, but if you have some ideas what to change/fix, feel free to ask for ACL's for devel branch at https://admin.fedoraproject.org/pkgdb/packages/name/libwvstreams ...
Comment 7 Ondrej Vasik 2009-03-30 10:06:30 EDT
Just as a note: required dbus changes done by William Lachance were just accepted by dbus upstream ( http://bugs.freedesktop.org/show_bug.cgi?id=19567 ) and they'll likely get to next dbus release...
Comment 8 Ondrej Vasik 2009-04-23 04:22:26 EDT
Dbus patch commited to git(http://cgit.freedesktop.org/dbus/dbus/commit/?id=16a947eedb7f7f2951fff4ebbf301af7776aa8df) and bug closed, so maybe you could try to persuade dbus maintainer to include it into rawhide - I can try to use patch from http://github.com/wlach/wvstreams/tree/dbus-refactoring in libwvstreams afterwards - to make the fix available sooner.
Comment 9 Bug Zapper 2009-06-09 06:36:56 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 10 Ondrej Vasik 2009-06-11 04:03:01 EDT
Built as libwvstreams-4.6-1.fc12 ... do you think it is worth of F-11 rebase/update or is enough to just close it rawhide?
Comment 11 Ondrej Vasik 2009-06-22 12:30:59 EDT
Closing RAWHIDE...
Comment 12 Konstantin Ryabitsev 2009-06-27 10:56:21 EDT
Thanks, Ondrej! I think we can just stick to working in rawhide, as F12 is supposed to be a short release anyway.
Comment 13 Konstantin Ryabitsev 2009-06-27 11:23:41 EDT
Sorry, looks like it still doesn't build with dbus, probably due to missing BR: dbus-devel. :)
Comment 14 Ondrej Vasik 2009-06-27 12:10:49 EDT
Ooops, probably... :)  I thought I already added that BR before... maybe I removed it afterwards. Working on one multilib issue with libwvstreams, hopefully will solve both together soon.
Comment 15 Ondrej Vasik 2009-06-27 12:43:34 EDT
Well, more issues as usually... ;)
BR dbus-devel and checking for libdbus-1.a instead of libdbus-1.so is solved, but error from configure "Checking that D-Bus version greater than 1.2.14 installed... no" can't be solved as dbus 1:1.2.12-1.fc11 is used at the build time. Therefore we need update of dbus to get further.
Comment 16 Ondrej Vasik 2009-06-27 12:51:15 EDT
Tried locally with dbus 1:1.2.14-1.fc12 (is in cvs, but not built in koji yet) and it builds with dbus now, so the only thing to be done is to build latest dbus in rawhide and to rebuild all dependent packages.
Comment 17 Ondrej Vasik 2009-06-28 04:05:03 EDT
Ok, dbus-1:1.2.14-1.fc12 now built in rawhide, so rebuilt with dbus support, it should now hopefully work.

checking Checking that D-Bus version greater than 1.2.14 installed.... yes
checking dbus/dbus.h usability... yes
checking dbus/dbus.h presence... yes
checking for dbus/dbus.h... yes
Wrote: /builddir/build/RPMS/libwvstreams-4.6-3.fc12.i586.rpm
Wrote: /builddir/build/RPMS/libwvstreams-devel-4.6-3.fc12.i586.rpm
Wrote: /builddir/build/RPMS/libwvstreams-debuginfo-4.6-3.fc12.i586.rpm

Closing RAWHIDE again.
Comment 18 Konstantin Ryabitsev 2009-07-03 22:45:08 EDT
Looks good! Thanks, Ondrej!

Note You need to log in before you can comment on or make changes to this bug.