Bug 479227 - can't run .jnlp files
can't run .jnlp files
Status: CLOSED DUPLICATE of bug 475109
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
10
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Lillian Angel
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-08 01:56 EST by Donald Cohen
Modified: 2009-01-11 11:38 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-11 11:38:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Donald Cohen 2009-01-08 01:56:34 EST
Description of problem:
I'm not sure how I'm supposed to run these but so far I can't do it.
I originally tried to run from a web page, firefox gave me choices like
open with icedtea web start (default) but none seem to work.
I eventually came to the conclusion (is this correct?) that the operation
above was supposed to run javaws, so I tried from shell:
$ which javaws
/usr/bin/javaws
[2009-01-07 22:40:47 root@number11 /tmp]
$ javaws -h
netx: Invalid jnlp file -h
[2009-01-07 22:41:04 root@number11 /tmp]
$ javaws /tmp/bpmn.jnlp 
netx: Launch Error: Could not launch JNLP file. (java.util.zip.ZipException error in opening zip file)
net.sourceforge.jnlp.LaunchException: Fatal: Launch Error: Could not launch JNLP file.
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:372)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:600)
Caused by: java.util.zip.ZipException: error in opening zip file
	at java.util.zip.ZipFile.open(Native Method)
	at java.util.zip.ZipFile.<init>(ZipFile.java:131)
	at java.util.jar.JarFile.<init>(JarFile.java:150)
	at java.util.jar.JarFile.<init>(JarFile.java:114)
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:345)
	... 1 more
Caused by: 
java.util.zip.ZipException: error in opening zip file
	at java.util.zip.ZipFile.open(Native Method)
	at java.util.zip.ZipFile.<init>(ZipFile.java:131)
	at java.util.jar.JarFile.<init>(JarFile.java:150)
	at java.util.jar.JarFile.<init>(JarFile.java:114)
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:345)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:600)
[2009-01-07 22:41:16 root@number11 /tmp]

On the other hand, I see in the file stuff about sun java...

Here's the file:

<?xml version='1.0'?><jnlp spec='1.0+'      codebase='http://pardemo02.ilog.fr/bpmnmodeler11/'      href='http://pardemo02.ilog.fr/bpmnmodeler11/bpmn.jnlp'      version='1.1.2'> <information>  <title>ILOG JViews BPMN Modeler</title>  <vendor>ILOG S.A.</vendor>  <description kind='short'>ILOG JViews BPMN Modeler</description>  <description kind='one-line'>A free BPMN Modeler developed with ILOG JViews Diagrammer</description>  <description kind='tooltip'>ILOG JViews BPMN Modeler</description>  <homepage href='http://www.ilog.com/products/jviews/diagrammer/bpmnmodeler'/>  <icon href='application.gif'/>  <icon href='splash.jpeg' kind='splash'/>  <icon href='shortcut.gif' kind='shortcut'/>  <offline-allowed/>  <shortcut online='true'>   <desktop/>   <menu submenu='ILOG'/>  </shortcut>  <association extensions='ibp' mime-type='application/ilog-bpmn'>   <description>ILOG JViews BPMN Modeler data file (.ibp)</description>  </association> </information> <update check='background' policy='prompt-update'/> <security>  <all-permissions/> </security> <application-desc/> <resources>  <j2se version='1.5.0+' href='http://java.sun.com/products/autodl/j2se'/>  <jar href='http://pardemo02.ilog.fr/bpmnmodeler11/bpmnmodeler.jar' version='1.1.2' main='true' download='eager'/> </resources></jnlp>

I don't know what this is supposed to do - I was hoping it would run some 
java application.

Version-Release number of selected component (if applicable):
I'm running a fedora 10 installation, which seems to contain
java-1.5.0-gcj.x86_64                     1.5.0.0-23.fc10              installed
java-1.6.0-openjdk.x86_64                 1:1.6.0.0-7.b12.fc10         installed
java-1.6.0-openjdk-plugin.x86_64          1:1.6.0.0-7.b12.fc10         installed
Comment 1 Omair Majid 2009-01-08 16:26:45 EST
Hi Donald,

You are correct, javaws is the right program to open jnlp files. IcedTea Webstart is another name for it. Here is a jnlp file that is known to work: http://www.progx.org/users/Gfx/apps/fuse-swing-demo.jnlp
Opening that link in firefox should work.

The ILOG website appears to be broken. The jnlp file points to http://pardemo02.ilog.fr/bpmnmodeler11/bpmnmodeler.jar as the jar to download and run. But that file doesn't exist: 
$ wget http://pardemo02.ilog.fr/bpmnmodeler11/bpmnmodeler.jar
--2009-01-08 15:54:13--  http://pardemo02.ilog.fr/bpmnmodeler11/bpmnmodeler.jar
Resolving pardemo02.ilog.fr... 81.80.162.209
Connecting to pardemo02.ilog.fr|81.80.162.209|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2009-01-08 15:54:13 ERROR 404: Not Found.

The jnlp file needs the jar file to even start, so with that missing, the application wont work.
Comment 2 Donald Cohen 2009-01-08 17:39:11 EST
I also tried and failed to download the jar.
Yet it does work in windows.
But your demo did work for me, so I've now sent a bug report to ilog
complaining that their .jnlp doesn't work on linux with openjdk.
One of the most annoying things is that the jar clearly has been downloaded on the windows machine, and if I could only figure out where it is (it seems not to have the original name!@#$) then I could copy it to my linux machine.  Ideas?
Comment 3 Omair Majid 2009-01-09 17:26:08 EST
On a closer look, this appears to be the same as bug 475109. The website doesnt support downloading a basic jar. A quick workaround is to download the versioned jar
$ wget http://pardemo02.ilog.fr/bpmnmodeler11/bpmnmodeler.jar?version-id=1.1.2
$ java -jar bpmnmodeler.jar\?version-id\=1.1.2
Comment 4 Lillian Angel 2009-01-11 11:38:18 EST

*** This bug has been marked as a duplicate of bug 475109 ***

Note You need to log in before you can comment on or make changes to this bug.