Bug 475109 - NullPointerException when launching JNLP file
NullPointerException when launching JNLP file
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: java-1.6.0-openjdk (Show other bugs)
10
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Omair Majid
Fedora Extras Quality Assurance
:
: 479227 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-07 16:48 EST by Jerry James
Modified: 2009-06-18 05:46 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-02 10:40:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jerry James 2008-12-07 16:48:06 EST
Description of problem:
I tried to install the Java Web Start application available at http://www.familysearchindexing.org/.  The browser popped up a window that showed messages about downloading a bunch of jars.  Then the window disappeared and nothing more happened.  I found this in ~/.xsession-errors:

*** NSPlugin Wrapper *** WARNING: unhandled variable 11 in NPP_GetValue()
*** NSPlugin Wrapper *** WARNING: unhandled variable 11 in NPP_GetValue()
*** NSPlugin Wrapper *** WARNING: unhandled variable 11 in NPP_GetValue()
*** NSPlugin Wrapper *** WARNING: unhandled variable 11 in NPP_GetValue()
*** NSPlugin Wrapper *** WARNING: unhandled variable 11 in NPP_GetValue()
*** NSPlugin Wrapper *** WARNING: unhandled variable 11 in NPP_GetValue()
Window manager warning: Invalid WM_TRANSIENT_FOR window 0x3c00007 specified for 0x3c00011 (Choose a c).
netx: Launch Error: Could not launch JNLP file. (java.lang.NullPointerException null)
net.sourceforge.jnlp.LaunchException: Fatal: Launch Error: Could not launch JNLP file.
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:372)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:600)
Caused by: java.lang.NullPointerException
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:358)
	... 1 more
Caused by: 
java.lang.NullPointerException
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:358)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:600)

Version-Release number of selected component (if applicable):
java-1.6.0-openjdk-1.6.0.0-6.b12.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Visit http://www.familysearchindexing.org/
2. Click on the software installation link in the lower left-hand corner

Actual results:
Jars are downloaded, but the application fails to start.

Expected results:
The application should start.

Additional info:
This appears to be similar to, but distinct from, bug #475081.
Comment 1 Deepak Bhole 2008-12-11 16:50:34 EST
This issue is happening due to combination of a bug in the site, and a missing feature in NetX. JNLP specifications allow for requesting a basic jar from the site afaict:

http://java.sun.com/j2se/1.5.0/docs/guide/javaws/developersguide/downloadservletguide.html#mapping

The download server that www.familysearchindexing.org redirects to, does not support basic download request. Since it is the only protocol NetX supports, the app fails to load.
Comment 2 Lillian Angel 2009-01-11 11:38:18 EST
*** Bug 479227 has been marked as a duplicate of this bug. ***
Comment 3 Lillian Angel 2009-02-02 10:40:06 EST
this should be in rawhide within the next couple of days:
http://koji.fedoraproject.org/koji/taskinfo?taskID=1098935
Comment 4 Russell Harrison 2009-02-03 10:56:06 EST
Should we expect the changes to be back ported once proven to work in rawhide or will F11 be the first stable release to see the fix?
Comment 5 Lillian Angel 2009-02-03 11:00:57 EST
will be in f-10 soon. the update has been requested
Comment 6 Russell Harrison 2009-02-03 13:02:47 EST
(In reply to comment #5)
> will be in f-10 soon. the update has been requested

Excellent, thanks for the update.
Comment 7 Fedora Update System 2009-02-04 21:23:29 EST
java-1.6.0-openjdk-1.6.0.0-9.b14.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Shi Yusen 2009-05-31 01:50:31 EDT
I ran a JNLP in Fedora 10 with java-1.6.0-openjdk-1.6.0.0-15.b14.fc10, Firefox 3.0.10 and got the similar problem:
net.sourceforge.jnlp.LaunchException: Fatal: Launch Error: Could not launch JNLP file.
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:372)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:600)
Caused by: java.lang.NullPointerException
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:358)
	... 1 more
Caused by: 
java.lang.NullPointerException
	at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:358)
	at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:600)

The JNLP can run on Windows XP with Sun JDK 1.5.0_06.

Is this the same bug or my mistake?
Comment 9 Omair Majid 2009-06-01 10:32:49 EDT
(In reply to comment #8)
> I ran a JNLP in Fedora 10 with java-1.6.0-openjdk-1.6.0.0-15.b14.fc10, Firefox
> 3.0.10 and got the similar problem:
> net.sourceforge.jnlp.LaunchException: Fatal: Launch Error: Could not launch
> JNLP file.
>  at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:372)
>  at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:600)
> Caused by: java.lang.NullPointerException
>  at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:358)
>  ... 1 more
> Caused by: 
> java.lang.NullPointerException
>  at net.sourceforge.jnlp.Launcher.launchApplication(Launcher.java:358)
>  at net.sourceforge.jnlp.Launcher$TgThread.run(Launcher.java:600)
> 
> The JNLP can run on Windows XP with Sun JDK 1.5.0_06.
> 
> Is this the same bug or my mistake?  

Could you please post a link to the JNLP file?
Comment 10 Shi Yusen 2009-06-18 05:46:12 EDT
We're writing a java client to launch on a static html page in a CD-ROM. Now we found how to resolve the problem:
In Windows JNLP:
<jnlp spec="1.0+" codebase="file:." href="search.jnlp">

In Linux JNLP:
<jnlp spec="1.0+" codebase="." href="linux_search.jnlp">

Sorry for disturbing you.

Note You need to log in before you can comment on or make changes to this bug.