Bug 479233 - Microsoft Exchange account cannot send mail
Microsoft Exchange account cannot send mail
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-08 02:31 EST by Cao, Chen
Modified: 2009-06-03 17:24 EDT (History)
7 users (show)

See Also:
Fixed In Version: evolution-2.24.3-2.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-22 12:16:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 563721 None None None Never

  None (edit)
Description Cao, Chen 2009-01-08 02:31:00 EST
Description of problem:
the MS Exchange account in evolution cannot send mail, while can 
receive mails successfully.


Version-Release number of selected component (if applicable):
evolution 2.24.2-3.f10


How reproducible:
100% reproducible on my machine.


Steps to Reproduce:
1. make sure you have a MS Exchange account set in evolution
2. select the account by click the name of the account in the 
account list (in the left-split window) and click 
'File -> New -> Mail Message' on the default menu of evolution.
3. make sure the sender is the MS Exchange account in the 
compose message window. fill the 'To' field with another 
MS Exchange account's email address, type whatever you like 
in the subject field and body of this mail.
4. click 'Send' to send the mail. a error message will appear 
on the statusbar.
5. try to receive mails. click 'Send/Receive' on the mail 
window of evolution.



Actual results:
evolution can successfully receive fetch mails from MS Exchange 
server, but
cannot send the mail, 
and the error message is 
'Error while performing operation.
 Exchange transport can only be used with Exchange mail source'



Expected results:
successfully send and receive mails.


Additional info:
I run evolution from terminal use command:
'evolution --debug ~/evolution.debug'

all the information I got is:
'(evolution:21147): evolution-shell-CRITICAL **: e_shell_set_crash_recovery: assertion `E_IS_SHELL (shell)' failed'
Comment 1 Peter Dieth 2009-01-13 11:40:37 EST
I also can reproduce this bug on my F10 system using evolution 2.24.2-3.f10 in combination with our MS Exchange Server 2003.
Sending emails via MS Exchange does not work - mail receiving does work.
Going back to evolution-2.24.1-2.fc10.i386 removed the problem.
Comment 2 Milan Crha 2009-01-13 13:06:03 EST
There were some changes in an account detection between those two versions. There will be released 2.24.3-1.fc10 very soon, where were also done some changes in this area. Can I ask you to retest with that version, please? Thanks in advance.
Comment 3 Phil Hale 2009-01-15 19:18:19 EST
I was having issues with evolution 2.24.2-3.fc10 x86_64 trying to send out mail.  It would tell me 
'Error while performing operation.
Exchange transport can only be used with Exchange mail source'

I was tracking this thread and saw your recommendation to use 2.24.3-1.fc10 from updates-testing.  I updated to the following packages from updates-testing:

evolution-data-server-2.24.3-1.fc10.x86_64
evolution-help-2.24.3-1.fc10.x86_64
evolution-2.24.3-1.fc10.x86_64
evolution-perl-2.24.3-1.fc10.x86_64
evolution-exchange-2.24.3-1.fc10.x86_64
evolution-conduits-2.24.3-1.fc10.x86_64

Now, when I try and set up a clean Exchange connection with evolution-exchange, Evolution crashes.  I ran it with the --debug option and I'm getting the following error:

(evolution:1493): camel-WARNING **: camel_type_register: 'CamelExchangeFolder' has smaller class size than parent 'CamelOfflineFolder'

(evolution:1493): camel-CRITICAL **: camel_object_is: assertion `o != NULL' failed

(evolution:1493): camel-CRITICAL **: camel_folder_construct: assertion `CAMEL_IS_FOLDER (folder)' failed

If I remove the exchange connector based connection, Evolution runs fine.
Comment 4 Milan Crha 2009-01-16 04:21:25 EST
(In reply to comment #3)
> Now, when I try and set up a clean Exchange connection with evolution-exchange,
> Evolution crashes.

Evolution-exchange was accidentally built against older evolution-data-server package, as stated in bug #480123. Please update evolution-exchange package to 2.24.3-2. I'm sorry for an inconvenience.
Comment 5 Milan Crha 2009-01-16 08:40:34 EST
Based on information from the upstream bug [1], this is really supposed to be fixed in 2.24.3.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=563721
Comment 6 Phil Hale 2009-01-16 12:50:32 EST
Upgrading to evolution-exchange-2.24.3-2.fc10.x86_64 as per http://bugzilla.gnome.org/show_bug.cgi?id=563721 seems to have resolved my issues.
Comment 7 Milan Crha 2009-01-19 07:29:36 EST
Phil, thanks for the update.

Cao, could you update to evolution-exchange-2.24.3-2 and report back whether it helps to you too? Thanks in advance.
Comment 8 Peter Dieth 2009-01-22 09:29:03 EST
I upgraded to evolution-exchange-2.24.3-2.fc10.i386 and now it works as designed.
Thank you very much for your fix!
Comment 9 Matthew Barnes 2009-01-22 12:16:41 EST
Thanks for the update.  I'll close this as fixed then.

Note You need to log in before you can comment on or make changes to this bug.