Bug 480123 - Evolution crashing on startup
Evolution crashing on startup
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
: 480377 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-15 04:19 EST by Espen Stefansen
Modified: 2009-01-21 16:25 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 16:25:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Espen Stefansen 2009-01-15 04:19:44 EST
Description of problem:
I tried the new evolution-packages from koji, trying to fix the problems with sending mail with exchange. When starting evolution, I get this:
(evolution:5578): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-mail.png
(evolution:5578): Bonobo-WARNING **: Could not find GNOME pixmap file /usr/share/icons/gnome/24x24/apps/evolution-tasks.png
(... and lots of those messages missing icons...)

(evolution:5578): camel-WARNING **: camel_type_register: 'CamelExchangeFolder' has smaller class size than parent 'CamelOfflineFolder'
(evolution:5578): camel-CRITICAL **: camel_object_is: assertion `o != NULL' failed
(evolution:5578): camel-CRITICAL **: camel_folder_construct: assertion `CAMEL_IS_FOLDER (folder)' failed

And then the program exits.

Version-Release number of selected component (if applicable):
evolution-2.24.3-1.fc10.i386
evolution-data-server-2.24.3-1.fc10.i386
evolution-exchange-2.24.3-1.fc10.i386


How reproducible:
Every time

Steps to Reproduce:
1. Start evolution
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Milan Crha 2009-01-15 06:01:59 EST
Version list seems correct to me. Can you try to either run this command:
   $ evolution --force-shutdown
or restart computer, thus new evolution-data-server and evolution-exchange-storage processes will be run, with correct structures, please?
Comment 2 Espen Stefansen 2009-01-15 06:39:04 EST
I've done that and I get the same error-messages.
Comment 3 Matthew Barnes 2009-01-15 09:45:43 EST
I think evolution-exchange-2.24.3-1.fc10 got built against the wrong evolution-data-server version.  I'm rebuilding it now against the correct version.  That should correct the problem.
Comment 4 Fedora Update System 2009-01-15 10:08:03 EST
evolution-exchange-2.24.3-2.fc10 has been submitted as an update for Fedora 10.
http://admin.fedoraproject.org/updates/evolution-exchange-2.24.3-2.fc10
Comment 5 Matthew Barnes 2009-01-16 15:59:22 EST
*** Bug 480377 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2009-01-16 18:48:10 EST
evolution-exchange-2.24.3-2.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update evolution-exchange'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-0682
Comment 7 Espen Stefansen 2009-01-19 07:40:33 EST
evolution-exchange-2.24.3-2.fc10 fixed everything for me. :)
Comment 8 Matthew Barnes 2009-01-19 08:44:17 EST
Okay good.  And sorry about that.  Packaging blunder on my part.

Getting positive reponses about 2.24.3 across the board, so I'll fasttrack this puppy into stable updates.
Comment 9 Fedora Update System 2009-01-21 16:25:54 EST
evolution-exchange-2.24.3-2.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.