Bug 479257 - Requires(postun) doesn't seem to have an effect on ordering package removal
Summary: Requires(postun) doesn't seem to have an effect on ordering package removal
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: FutureFeature
: 478842 490975 532461 583424 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2009-01-08 13:30 UTC by Caolan McNamara
Modified: 2014-01-21 23:07 UTC (History)
13 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2009-12-07 16:16:59 UTC


Attachments (Terms of Use)
yum log (7.41 KB, text/plain)
2009-01-08 13:30 UTC, Caolan McNamara
no flags Details
yum log (7.26 KB, text/plain)
2009-06-15 15:55 UTC, Jerry Amundson
no flags Details

Description Caolan McNamara 2009-01-08 13:30:12 UTC
Created attachment 328463 [details]
yum log

Description of problem:

Version-Release number of selected component (if applicable):
yum-3.2.20-8.fc11

How reproducible:
100%

Steps to Reproduce:
1. yum -y erase openoffice.org-fonts openoffice.org-ure
just to remove all openoffice.org components to clear the decks
2. yum -y install openoffice.org-pdfimport
3. yum -y -v erase openoffice.org-core openoffice.org-pdfimport
  
Actual results:
openoffice.org-core gets erased after openoffice.org-pdfimport does, so the use of unopkg in openoffice.org-pdfimport fails as it has already been deleted

Expected results:
That the Requires(postun): openoffice.org-core would cause openoffice.org-pdfimport to be removed before openoffice.org-core

Comment 1 Caolan McNamara 2009-01-08 13:31:07 UTC
Actual results:
openoffice.org-core gets erased *before* openoffice.org-pdfimport does, so the use of unopkg in openoffice.org-pdfimport fails as it has already been deleted

Comment 2 seth vidal 2009-01-21 18:56:59 UTC
reassigning since ordering is handled by rpm.

Comment 3 Jeff Johnson 2009-01-22 01:44:40 UTC
Yes, the version of RPM you are using does not have erasure ordering implemented,
and so
      Requires(postun): openoffice.org-core
which affects the erasure ordering context, doesn't apply. Period.

What _IS_ implemented in the RPM you are using, in lieu of proper
erasure ordering, is reversed install ordering, that's __ALMOST__
gud enuf. But the Requires(postun): context marker is ignored for
reversed install ordering.

Comment 4 Caolan McNamara 2009-01-22 08:48:56 UTC
Why was the "needinfo" from me flag set ? What info is needed ?

Comment 5 seth vidal 2009-01-22 12:20:36 UTC
Caolan,
 That was my fault. I was working on a bunch of bugs at the same time and I probably hit it mistakenly.
sorry.

Comment 6 Jens Petersen 2009-02-13 02:05:13 UTC
And nor does Requires(preun) for me, or even Requires??  Maybe I am missing something but this looks kind of bad to me...

Comment 7 Jens Petersen 2009-02-13 02:22:08 UTC
It seems a significant change of behaviour to me.  I propose it should be a F11Blocker.

Comment 8 Jeff Johnson 2009-02-13 02:45:47 UTC
The lack of erasure ordering in rpm was _ALREADY_ a FC4 blocker. Certainly, make lack of
erasure ordering a F11 ordering as you wish. In fact, the erasure ordering development
in rpm was started the day that FC4 was released, and was largely finished 7 days later.

Two (or was it three, I fergit), years ago ...

Comment 9 Bug Zapper 2009-06-09 10:37:27 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 10 Jerry Amundson 2009-06-15 15:55:52 UTC
Created attachment 347957 [details]
yum log

Comment 11 Panu Matilainen 2009-06-18 17:15:38 UTC
This isn't a regression, erasure ordering isn't really implemented in current released rpm versions. Current rpm.org HEAD has it though, whether it'll make it to F12 is another story as its linked to some API changes that make it unsuitable for pulling into 4.7.x as is.

Comment 12 Panu Matilainen 2009-06-18 17:16:30 UTC
*** Bug 478842 has been marked as a duplicate of this bug. ***

Comment 13 Panu Matilainen 2009-06-18 17:17:19 UTC
*** Bug 490975 has been marked as a duplicate of this bug. ***

Comment 14 Caolan McNamara 2009-11-05 09:35:51 UTC
*** Bug 532461 has been marked as a duplicate of this bug. ***

Comment 15 Panu Matilainen 2009-12-07 16:16:59 UTC
rpm 4.8.0-beta1 in rawhide (finally) has proper erasure ordering.

Comment 16 David Tardon 2010-04-18 14:35:36 UTC
*** Bug 583424 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.