Bug 583424 - Errors on uninstall - insufficient requires
Summary: Errors on uninstall - insufficient requires
Keywords:
Status: CLOSED DUPLICATE of bug 479257
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 12
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2010-04-18 13:45 UTC by Mads Kiilerich
Modified: 2010-04-18 20:51 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-04-18 14:35:36 UTC


Attachments (Terms of Use)

Description Mads Kiilerich 2010-04-18 13:45:29 UTC
yum -y remove openoffi*
...
  Erasing   : 1:openoffice.org-graphicfilter-3.1.1-19.28.fc12.i686    1/20 
  Erasing   : 1:openoffice.org-ure-3.1.1-19.28.fc12.i686    2/20 
  Erasing   : 1:openoffice.org-math-3.1.1-19.28.fc12.i686    3/20 
  Erasing   : 1:openoffice.org-draw-core-3.1.1-19.28.fc12.i686    4/20  
  Erasing   : 1:openoffice.org-impress-3.1.1-19.28.fc12.i686    5/20 
  Erasing   : openoffice.org-writer2xhtml-1.0-1.fc12.i686    6/20 
/usr/lib/openoffice.org3/program/unopkg.bin: error while loading shared libraries: libuno_sal.so.3: cannot open shared object file: No such file or directory
  Erasing   : 1:openoffice.org-calc-3.1.1-19.28.fc12.i686    7/20 
  Erasing   : 1:openoffice.org-draw-3.1.1-19.28.fc12.i686    8/20 
  Erasing   : 1:openoffice.org-calc-core-3.1.1-19.28.fc12.i686    9/20  
  Erasing   : 1:openoffice.org-writer-3.1.1-19.28.fc12.i686    10/20 
  Erasing   : 1:openoffice.org-pdfimport-3.1.1-19.28.fc12.i686    11/20 
/usr/lib/openoffice.org3/program/unopkg.bin: error while loading shared libraries: libuno_sal.so.3: cannot open shared object file: No such file or directory
  Erasing   : 1:openoffice.org-core-3.1.1-19.28.fc12.i686    12/20 
  Erasing   : 1:openoffice.org-langpack-en-3.1.1-19.28.fc12.i686    13/20 
  Erasing   : 1:openoffice.org-math-core-3.1.1-19.28.fc12.i686    14/20 
  Erasing   : 1:openoffice.org-writer-core-3.1.1-19.28.fc12.i686    15/20 
  Erasing   : 1:openoffice.org-impress-core-3.1.1-19.28.fc12.i686    16/20 
  Erasing   : 1:openoffice.org-xsltfilter-3.1.1-19.28.fc12.i686    17/20 
  Erasing   : 1:openoffice.org-opensymbol-fonts-3.1.1-19.28.fc12.noarch    18/20
  Erasing   : 1:openoffice.org-brand-3.1.1-19.28.fc12.i686    19/20
  Erasing   : 1:openoffice.org-presenter-screen-3.1.1-19.28.fc12.i686    20/20 
/var/tmp/rpm-tmp.9YMTtW: line 3: unopkg: command not found

Comment 1 David Tardon 2010-04-18 14:35:36 UTC
the requires are sufficient, it's just that rpm doesn't respect them...

*** This bug has been marked as a duplicate of bug 479257 ***

Comment 2 Mads Kiilerich 2010-04-18 20:51:00 UTC
Confirmed solved in F13


Note You need to log in before you can comment on or make changes to this bug.