Bug 479270 - mkinitrd 5.1.19.6-44 fails to create initrd for kernels prior to 2.6.18-122.el5
Summary: mkinitrd 5.1.19.6-44 fails to create initrd for kernels prior to 2.6.18-122.el5
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd
Version: 5.3
Hardware: All
OS: Linux
urgent
high
Target Milestone: rc
: ---
Assignee: Peter Jones
QA Contact: Alexander Todorov
URL:
Whiteboard:
Keywords: ZStream
: 488991 (view as bug list)
Depends On:
Blocks: 496591
TreeView+ depends on / blocked
 
Reported: 2009-01-08 15:06 UTC by Olivier Fourdan
Modified: 2018-10-20 02:29 UTC (History)
12 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2009-09-02 11:15:03 UTC


Attachments (Terms of Use)
Proposed patch (473 bytes, patch)
2009-01-08 15:06 UTC, Olivier Fourdan
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1345 normal SHIPPED_LIVE mkinitrd bug fix and enhancement update 2009-09-01 10:45:45 UTC

Description Olivier Fourdan 2009-01-08 15:06:45 UTC
Created attachment 328467 [details]
Proposed patch

Description of problem:

5.1.19.6-44 includes a fix for bug #476866 that breaks with kernel prior to 2.6.18-122.el5 which have no module dm-mem-cache dm-region_hash dm-message or dm-raid45.

Version-Release number of selected component (if applicable):

mkinitrd-5.1.19.6-44

How reproducible:

100% reproducible

Steps to Reproduce:
1. install mkinitrd-5.1.19.6-44
2. Run kernel 2.6.18-120.el5
3. mkinitrd initrd-$(uname -r) $(uname -r)
  
Actual results:

No module dm-mem-cache found for kernel 2.6.18-120.el5, aborting.

Expected results:

initrd-2.6.18-120.el5 created

Additional info:

I think the fix for bug #476866 should have been:


   if [ "$withdmraid" == "1" ]; then
       findmodule -dm-mem-cache
       findmodule -dm-region_hash
       findmodule -dm-message
       findmodule -dm-raid45
   fi


ie use "-" which instructs findmodule not to break if the module is not present.

Comment 1 RHEL Product and Program Management 2009-01-08 15:23:23 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 7 Peter Jones 2009-04-17 19:40:29 UTC
This is fixed in mkinitrd-5.1.19.6-45 .

Comment 12 Peter Jones 2009-05-18 15:15:21 UTC
*** Bug 488991 has been marked as a duplicate of this bug. ***

Comment 15 Alexander Todorov 2009-05-26 14:33:35 UTC
On a RHEL5.2 machine I've upgraded mkinitrd to version 5.1.19.6-44 which is the one reported to fail. 

# rpm -q mkinitrd
mkinitrd-5.1.19.6-44

# uname -a
Linux dell-pe650-02.rhts.bos.redhat.com 2.6.18-92.el5 #1 SMP Tue Apr 29 13:16:12 EDT 2008 i686 i686 i386 GNU/Linux
# mkinitrd test-$(uname -r) $(uname -r)
No module dm-mem-cache found for kernel 2.6.18-92.el5, aborting.


Then upgrade mkinitrd to the latest available version.

# rpm -q mkinitrd
mkinitrd-5.1.19.6-52

# uname -a
Linux dell-pe650-02.rhts.bos.redhat.com 2.6.18-92.el5 #1 SMP Tue Apr 29 13:16:12 EDT 2008 i686 i686 i386 GNU/Linux

# mkinitrd test-$(uname -r) $(uname -r)
cat: /proc/sys/crypto/fips_enabled: No such file or directory
/sbin/mkinitrd: line 1171: [: : integer expression expected
/sbin/mkinitrd: line 1663: [: : integer expression expected
/sbin/mkinitrd: line 1748: [: : integer expression expected


# echo $?
0

The initrd image is created but notice the errors. I guess that's another bug. QE will need to re-test this once the errors are fixed. 

Tested on i386 and ia64 since customer is using ia64 in comment #9.

Comment 16 Alexander Todorov 2009-05-26 14:42:56 UTC
QE Note: please test after bug #502624 has been verified.

Comment 17 Peter Jones 2009-05-26 18:52:33 UTC
Alexander, this bug can be tested against mkinitrd-5.1.19.6-45 , as I said above in comment #7.  It need not block on 502624.

Comment 18 Alexander Todorov 2009-05-27 08:16:49 UTC
# ls -l /proc/sys/crypto/fips_enabled
ls: /proc/sys/crypto/fips_enabled: No such file or directory
# rpm -q mkinitrd
mkinitrd-5.1.19.6-53
# uname -a
Linux athlon5 2.6.18-92.el5 #1 SMP Tue Apr 29 13:16:12 EDT 2008 i686 athlon
i386 GNU/Linux
# mkinitrd test-$(uname -r) $(uname -r)
# echo $?
0
# ls -l test-2.6.18-92.el5 
-rw------- 1 root root 3118733 May 27 04:09 test-2.6.18-92.el5

initrd image is created and no error for /proc/sys/crypto/fips_enabled. Tested
on i386 and ia64 since customer is using ia64 in comment #9. Moving to VERIFIED.

Comment 24 errata-xmlrpc 2009-09-02 11:15:03 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1345.html


Note You need to log in before you can comment on or make changes to this bug.