This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 488991 - mkinitrd erroneously inserts dependencies to dm-mem-cache (not present on MRG)
mkinitrd erroneously inserts dependencies to dm-mem-cache (not present on MRG)
Status: CLOSED DUPLICATE of bug 479270
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: mkinitrd (Show other bugs)
5.3
All Linux
high Severity medium
: rc
: ---
Assigned To: Peter Jones
Release Test Team
:
Depends On: 482753
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-06 11:49 EST by Clark Williams
Modified: 2009-05-18 11:15 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 482753
Environment:
Last Closed: 2009-05-18 11:15:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Clark Williams 2009-03-06 11:49:47 EST
+++ This bug was initially created as a clone of Bug #482753 +++

Arnaldo hit the warning that Shak and Jcm have seen earlier and investigated the issue a bit.

That seems to be the origin of this issue:

# rpm -q --changelog mkinitrd
* Wed Dec 17 2008 Peter Jones <pjones@redhat.com> - 5.1.19.6-44
 - Include dm-raid45 and related modules if dmraid is in use.
   Resolves: rhbz#476866

Symptoms:

# mkinitrd /boot/initrd-2.6.24-100.el5rt.tsc1.img 2.6.24-100.el5rt.tsc1
No module dm-mem-cache found for kernel 2.6.24-100.el5rt.tsc1, aborting.

or

# /sbin/new-kernel-pkg --package kernel-rt --banner "Red Hat Enterprise Linux (realtime)" --mkinitrd --depmod --install 2.6.24-100.el5rt.tsc1
WARNING: No module dm-mem-cache found for kernel 2.6.24-100.el5rt.tsc1, continuing anyway
WARNING: No module dm-region_hash found for kernel 2.6.24-100.el5rt.tsc1, continuing anyway
WARNING: No module dm-message found for kernel 2.6.24-100.el5rt.tsc1, continuing anyway
WARNING: No module dm-raid45 found for kernel 2.6.24-100.el5rt.tsc1, continuing anyway

--- Additional comment from jneedle@redhat.com on 2009-02-03 11:36:59 EDT ---

Good news and bad news.  mkinitrd-5.1.19.6-44 only shipped in 5.3, and since the 1.1.1 candidate was shipped for 1.1, we support 5.2.  This will have to be revisited, though, when the next release goes out that targets 5.3.

--- Additional comment from lgoncalv@redhat.com on 2009-03-03 15:40:36 EDT ---

Created an attachment (id=333925)
Patch for the mkinitrd/dmraid issue

One possible solution.

This patch creates a functions called try_findmodule(), used only to locate dmraid modules, that will silently ignore these modules if they are not present in the kernel being installed.

By the number of reports we received about the mkinitrd WARNINGS during MRG RT kernel installation, I believe support folks will like this solution best as it may avoid bogus support tickets.

before:
   # mkinitrd /boot/initrd-2.6.24.7-107.el5rt.img 2.6.24.7-107.el5rt
   No module dm-mem-cache found for kernel 2.6.24.7-107.el5rt, aborting.

After:

   # mkinitrd /boot/initrd-2.6.24.7-107.el5rt.img 2.6.24.7-107.el5rt
   #

--- Additional comment from lgoncalv@redhat.com on 2009-03-03 15:44:35 EDT ---

Created an attachment (id=333927)
Another patch for the mkinitrd/dmraid issue

Another possible solution [ just for the sake of completeness as the other patch is better ].

This patch creates a functions called try_findmodule(), used only to locate
dmraid modules, that will ignore these modules if they are not present
in the kernel being installed, but will issue the scary warning from mkinitrd.

By the number of reports we received about the mkinitrd WARNINGS during MRG RT
kernel installation, I believe support folks will preffer the other solution as it may avoid bogus support tickets.

before:
   # mkinitrd /boot/initrd-2.6.24.7-107.el5rt.img 2.6.24.7-107.el5rt
   No module dm-mem-cache found for kernel 2.6.24.7-107.el5rt, aborting.

After:

   # mkinitrd /boot/initrd-2.6.24.7-107.el5rt.img 2.6.24.7-107.el5rt
   WARNING: No module dm-mem-cache found for kernel 2.6.24.7-107.el5rt, continuing anyway
   WARNING: No module dm-region_hash found for kernel 2.6.24.7-107.el5rt, continuing anyway
   WARNING: No module dm-message found for kernel 2.6.24.7-107.el5rt, continuing anyway
   WARNING: No module dm-raid45 found for kernel 2.6.24.7-107.el5rt, continuing anyway
Comment 1 Clark Williams 2009-03-11 16:51:40 EDT
Note that this succeeds when run as part of an RPM install, evidently because rpm uses the (undocumented) option --allow-missing. You still get the warning messages listed above.

If you run mkinitrd by hand on a MRG RT system, without using the --allow-missing option, the command will abort.
Comment 2 Peter Jones 2009-05-18 11:15:21 EDT

*** This bug has been marked as a duplicate of bug 479270 ***

Note You need to log in before you can comment on or make changes to this bug.