Bug 479315 - img2qcow program crashes...
img2qcow program crashes...
Status: CLOSED DUPLICATE of bug 486353
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.4
All Linux
low Severity high
: rc
: ---
Assigned To: Michal Novotny
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-08 14:50 EST by Gurhan Ozen
Modified: 2014-02-02 17:36 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-23 03:15:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gurhan Ozen 2009-01-08 14:50:50 EST
Description of problem:
 
# img2qcow RH52_x86_64_pv_guest_sp.qcow RH52_x86_64_pv_guest_sp.img
Image size: [10485760]
Created cksum: -626982689
File truncated to length 5370044416
Qcow file created: size 10485760 sectors
Segmentation fault (core dumped)

(gdb) bt
#0  0x0000003147a758bb in free () from /lib64/libc.so.6
#1  0x0000000000403096 in free_aio_state (dd=<value optimized out>) at block-qcow.c:167
#2  0x0000000000405292 in tdqcow_open (dd=0x7fff17474cc0, name=0x18d2a060 "\005", flags=<value optimized out>) at block-qcow.c:1004
#3  0x0000000000406dba in main (argc=<value optimized out>, argv=0x7fff17474e38) at img2qcow.c:204

Version-Release number of selected component (if applicable):
xen-3.0.3-80.el5

How reproducible:
Very

Steps to Reproduce:
1. Try to convert a guest image to qcow image using img2qcow .
2.
3.
  
Actual results:
Crashes...

Expected results:
Shouldn't crash.
Comment 1 Daniel Berrange 2009-02-20 15:44:42 EST
Wouldn't be surprised if this is fallout from bug 486353, since this command line tools shares the same IO code as blktap
Comment 2 Michal Novotny 2009-02-23 03:15:29 EST
Well, I tried it myself after patches for 486353 and 485471 (available on both BZ and they have been also sent to virtualist mailing list) applied and it worked fine for me... Here's my output:

# img2qcow test.qcow test.img
Image size: [1294088]
Created cksum: 114489210
File truncated to length 662743040
Qcow file created: size 1294088 sectors
[=====================]     100%
TRANSFER COMPLETE

Writing cksum: 228597921

So that I think this should be already OK but if any problems found, please report them. I am closing it with duplicate status now...

*** This bug has been marked as a duplicate of bug 486353 ***

Note You need to log in before you can comment on or make changes to this bug.