Bug 486353 - Fix missing blktap poll-on-aio support
Fix missing blktap poll-on-aio support
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.4
All Linux
low Severity medium
: rc
: ---
Assigned To: Michal Novotny
Virtualization Bugs
:
: 479315 (view as bug list)
Depends On:
Blocks: 485471
  Show dependency treegraph
 
Reported: 2009-02-19 08:59 EST by Michal Novotny
Modified: 2014-02-02 17:36 EST (History)
4 users (show)

See Also:
Fixed In Version: xen-3.0.3-86.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-02 06:11:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Poll-on-aio support fix (17.59 KB, patch)
2009-02-20 06:27 EST, Michal Novotny
no flags Details | Diff
Updated version of my patch (17.74 KB, patch)
2009-05-11 04:18 EDT, Michal Novotny
no flags Details | Diff

  None (edit)
Description Michal Novotny 2009-02-19 08:59:06 EST
Description of problem:
When using any other image type than raw in PV guest or FV guest with PV drivers used (using BLKTAP & TAPDISK), eg. qcow, tapdisk returns segfault because of missing poll-on-aio support which results in image is not seen on PV guest.

Version-Release number of selected component (if applicable):


How reproducible:
Adding tap:qcow:/path/to image file to PV Xen domain configuration and starting this domain won't show those devices in /dev tree.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Michal Novotny 2009-02-20 06:27:04 EST
Created attachment 332692 [details]
Poll-on-aio support fix

This is a poll-on-aio support fix for qcow images for VMs that are using PV drivers (PV guests, FV guests with PV drivers). It's a backport of upstream at http://xenbits.xensource.com/xen-unstable.hg?rev/eeeb77195ac2.

Michal
Comment 2 Michal Novotny 2009-02-23 03:15:29 EST
*** Bug 479315 has been marked as a duplicate of this bug. ***
Comment 3 Michal Novotny 2009-05-11 04:18:51 EDT
Created attachment 343344 [details]
Updated version of my patch

This is updated/reindented version of my patch...
Michal
Comment 4 Jiri Denemark 2009-05-21 11:40:40 EDT
Fix built into xen-3.0.3-86.el5
Comment 6 Yewei Shao 2009-07-28 01:56:53 EDT
Verify on xen-3.0.3-91.el5.x86_64
Comment 8 errata-xmlrpc 2009-09-02 06:11:39 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1328.html

Note You need to log in before you can comment on or make changes to this bug.