Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 479468 - grub splash screen missing
grub splash screen missing
Status: CLOSED DUPLICATE of bug 473319
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
rawhide
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-09 15:52 EST by Jonathan Pritchard
Modified: 2009-05-31 06:15 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-31 06:15:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Picture of the problem in question. (700.16 KB, image/jpeg)
2009-01-28 06:16 EST, Jonathan Pritchard
no flags Details

  None (edit)
Description Jonathan Pritchard 2009-01-09 15:52:49 EST
Description of problem:

The grub screen with the timeout which when interrupted leads you to choose which operating system to boot is missing it's splash screen.

All that can be seen is the writing with the usual notice of e.g 'Starting 'Other' in 5 seconds' but the rest of the screen other than the writing is just black.

If you interrupt you advance to the next page of GRUB which looks fine and normal as expected.

Version-Release number of selected component (if applicable):
Default in Fedora 10, although have done a full system update since.

How reproducible:
Everytime.

Expected results:

Instead of just the text there is usually a page resembling if not exactly the grub splash screen with the artwork like there is for the operating system choosing page.
Comment 1 Jonathan Pritchard 2009-01-09 16:13:17 EST
I should add that I am dual-booting with Windows Vista.

Initially when installing I told anaconda to not overwrite the mbr but I later had to go into rescude mode and execute 'grub-install /dev/sda'.

Perhaps this unusual method explains why not many have experienced it.

Although I have found two others who have the same problem -- http://forums.fedoraforum.org/showthread.php?p=1145655#post1145655
Comment 2 Dennis Magee 2009-01-28 00:04:49 EST
I had the same issue and found that if you comment out the hiddenmenu part of the grub.conf file, all that will show is the splash screen with your options. you can comment hiddenmenu by putting a # before it.

The problem is because fedora 10 only supports newer ATI video cards by default
Comment 3 Jonathan Pritchard 2009-01-28 06:16:52 EST
Created attachment 330220 [details]
Picture of the problem in question.

It's quite hard to explain in words what is exactly wrong so a picture illustrates this better. Sorry about the poor quality it's from a phone camera.
Comment 4 Dennis Magee 2009-01-28 22:12:09 EST
Yea that is exactly the problem I was having. Was also having an issue with my screen flickering during the shutdown process but that's another story. Here is what you need to do

1. log in as root
2. open a terminal
3. type in "gedit /boot/grub/grub.conf" (without quotes)
4. find the line that says "hiddenmenu"
5. put a # before "hiddenmenu"
6. save the file
7. restart the laptop and it should be fine

Also you can edit the file so that it says Booting Windows Vista instead of Booting Other. Hope this helps and let me know how it goes for you
Comment 5 Jonathan Pritchard 2009-01-29 10:17:22 EST
I've followed your steps. However it merely removes the first page that GRUB shows and goes straight to presenting the list to choose from, and the timeout is miniscule it just waits there a second and boots the default OS. Is there a way to keep the former screen and restore it to it's glory? And is there a way to increase the timeout with your workaround?
Comment 6 Dennis Magee 2009-01-29 15:30:30 EST
Here is a sample of my grub.conf file off of my Red Hat Enterprise Computer. The line that says "timeout=5" mean the timeout to choose between OS's is 5 seconds. You can increase that to whatever you want.

Now about the former screen, like I said before, Fedora 10 only supports newer ATI video cards by default. If you don't have one, it's not going to bring back the former screen from what I know

Do you by any chance get a Graphical Boot Interface (GBI) when Fedora boots up, or do you only get text that tells you the processes starting? The GBI is a pretty looking sun with a progress bar

Also, can you send a copy of your grub.conf file?

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,0)
#          kernel /vmlinuz-version ro root=/dev/VolGroup00/LogVol00
#          initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,0)/grub/splash.xpm.gz
#hiddenmenu
title Red Hat Enterprise Linux Client (2.6.18-128.el5)
	root (hd0,0)
	kernel /vmlinuz-2.6.18-128.el5 ro root=/dev/VolGroup00/LogVol00 rhgb quiet
	initrd /initrd-2.6.18-128.el5.img
title Windows Vista
	rootnoverify (hd1,0)
	chainloader +1
Comment 7 Jonathan Pritchard 2009-01-29 16:40:16 EST
GRUB.conf as follows:

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,2)
#          kernel /vmlinuz-version ro root=/dev/sda6
#          initrd /initrd-version.img
#boot=/dev/sda3
default=3
timeout=5
splashimage=(hd0,2)/grub/splash.xpm.gz
#hiddenmenu
title Fedora (2.6.27.12-170.2.5.fc10.i686)
	root (hd0,2)
	kernel /vmlinuz-2.6.27.12-170.2.5.fc10.i686 ro root=UUID=27e2541d-1abc-45d0-8026-f0f11e70e73c rhgb quiet vga=0x368
	initrd /initrd-2.6.27.12-170.2.5.fc10.i686.img
title Fedora (2.6.27.9-159.fc10.i686)
	root (hd0,2)
	kernel /vmlinuz-2.6.27.9-159.fc10.i686 ro root=UUID=27e2541d-1abc-45d0-8026-f0f11e70e73c rhgb quiet vga=0x368
	initrd /initrd-2.6.27.9-159.fc10.i686.img
title Fedora (2.6.27.5-117.fc10.i686)
	root (hd0,2)
	kernel /vmlinuz-2.6.27.5-117.fc10.i686 ro root=UUID=27e2541d-1abc-45d0-8026-f0f11e70e73c rhgb quiet vga=0x368
	initrd /initrd-2.6.27.5-117.fc10.i686.img
title Windows Vista Business
	rootnoverify (hd0,1)
	chainloader +1

--

I see Plymouth as I I added a vga argument to the kernel line for my resolution (1280x800) and this allows me to see plymouth even though the Intel drivers currently don't support kernel-based mode-setting.

I've edited the timeout before and it is for the former screen. I don't understand what you mean by only the ATI drivers will allow me to see that screen since before commenting out the 'hiddenmenu' line it showed up fine, but with the graphical glitch that this bug is about. Is this no the expected behaviour? Is this old deprecated behaviour?

Thanks for your help. I'll try changing the timeout and see if that has any effect. It's just when I followed your steps and restarted the GRUB screen went by in a flash, not really 5 seconds.
Comment 8 Dennis Magee 2009-01-29 19:01:08 EST
ATI is a video card company. You said you have Intel so you don't have an ATI card. The reason why you had to put the vga argument is because you don't have an ATI video card in you laptop. Because it is a laptop you cannot change the video card. So until the Fedora people increase the amount of video cards they do support, we wont be able to see that screen clearly. I personally like seeing the list anyway, but if you want to go back to the way it was, its your choice. Sorry I can't really help further

Also, you should uninstall the older kernels to save disk space.
Comment 9 Jonathan Pritchard 2009-01-30 10:51:21 EST
Thank-you for trying to help.

So not being able to see the grub artwork properly when hiddenmenu is activated is actually the expected behaviour.

I thought kernel-based mode-setting was just meant to provide a flicker free transition. I don't see why it wouldn't be able to show the artwork fully on that page when it can show it on the menu page.

I understand that this is all meant to work seamlessly with 2.6.29 and the new Intel driver in the next release of Fedora. But I just don't see why it can show the page without showing the proper artwork. That is what this bug is about. I don't think it has anything to do with the Intel driver currently not having kernel-based mode-setting - that is what I'm trying to find out.
Comment 10 Eelko Berkenpies 2009-02-09 09:34:59 EST
I've got the same problem running F10 and Windows XP dual boot. The grub splash screen appears to be broken while the OS selection screen has no issues and the background is being displayed fine.

The OS's are on two different HDD's. Fedora is located on the first HDD and so is the grub boot loader. I'd post my grub.conf but I'm not at home at the moment, see remark below (videocard). Windows is located on the second HDD. The bios points to the first HDD as the default boot disk.

My system is currently up to date and I have had this problem since the installation (about 1,5-2 months ago). My videocard is a nVidia GeForce FX 5200 (or 5500 - I am not at home so I cannot verify this, if it really matters, let me know and I'll find out).

I agree on the statement in comment #9. The menu works fine so I "expect" the splash screen to do so too. :)

If more information is needed, I'd be happy to share. Just let me know.

PS. visually it looks exactly as the image posted in comment #3.
Comment 11 Orcan Ogetbil 2009-02-14 10:24:15 EST
(In reply to comment #6)
> Do you by any chance get a Graphical Boot Interface (GBI) when Fedora boots up,
> or do you only get text that tells you the processes starting? The GBI is a
> pretty looking sun with a progress bar
> 

Really?? A few months ago I read on the fedora-devel ML that rhgb is being replaced to avoid flickering during bootup. When I installed F-10, I felt that something weird was going on, and what was changed is definitely not an improvement over what we had:

- I have no Windows installed.
- I get the same corrupt screen as in the screenshot in comment #3, which returns to the regular grub manu when I press a key.
- After that corrupt screen I get a one-line message on top of the screen, black background, white fonts (sorry I don't remember the message)
- Then there is an ASCII progress bar at the bottom of the screen. Not very pretty.
- When the progressbar is ~30% full, a writing on the right hand side of the progress bar appears. It says (Fedora 10).
- There is still flickering, when switching to X.

I don't get that "beautiful sun". I wasn't even aware of its existence until I read your message.

Switching from a graphical rhgb to an ASCII progress bar, while still having the flickers, is certainly not an improvement.

Who shall we blame?
Comment 12 Orcan Ogetbil 2009-02-14 10:39:39 EST
I'm not sure whether this is a GRUB bug and I wish the bug assignee replied to this thread.

I added the primary plymouth maintainer to CC
Comment 13 Eelko Berkenpies 2009-03-18 08:54:03 EDT
For what it's worth, I've recently seen the exact same behavior on an other PC here at the office (single boot Fedora 10 installation) and on my own laptop running a single boot Rawhide installation (currently up to date).

@Orcan: you might have figured it out already but here's a link to a workaround for the beautiful sun http://www.my-guides.net/en/content/view/125/26/1/12/#plymouth
Comment 14 Thomas Janssen 2009-05-28 10:27:19 EDT
Jonathan, this Bugreport wasn't a bug at all and filed against the wrong component. We're although glad you got it working as expected.

I will close this Report now as Notabug. Please feel free to report any further issues you may face with Fedora to this bugzilla.

For future reference, you can as well visit the IRC-Channel #fedora on freenode.net to get fast help with such issues.

Thank you for contributing!

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 15 Thomas Janssen 2009-05-30 12:19:52 EDT
Reopened and moved to grub.

-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 16 Eelko Berkenpies 2009-05-31 06:15:16 EDT

*** This bug has been marked as a duplicate of bug 473319 ***

Note You need to log in before you can comment on or make changes to this bug.