Bug 473319 - GRUB background is only shown around text, rest of the screen remains black
GRUB background is only shown around text, rest of the screen remains black
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: grub (Show other bugs)
12
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
: Reopened, Triaged
: 479468 499985 507063 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-27 12:15 EST by Stewart Adam
Modified: 2010-07-08 17:13 EDT (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-07-08 16:55:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Picture of the screen as GRUB is showing (331.62 KB, image/png)
2008-11-27 12:15 EST, Stewart Adam
no flags Details
drop in replacement for the existing grub-keystatus.patch (17.24 KB, patch)
2009-05-31 06:14 EDT, Eelko Berkenpies
no flags Details | Diff

  None (edit)
Description Stewart Adam 2008-11-27 12:15:31 EST
Created attachment 324905 [details]
Picture of the screen as GRUB is showing

Description of problem:
After installing Fedora 10, the GRUB menu shows as expected however the background isn't shown. The only place where it is visible is directly behind text characters (see attached image).

Version-Release number of selected component (if applicable):
grub-0.97-38.fc10.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Reboot
  
Actual results:
Entire background is shown, not just under text.

Expected results:
Background image is shown

Additional info:
Pressing a key to enter the boot menu results in the background being shown correctly.

Output of lspci | grep VGA:
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600M GT (rev a1)
Comment 1 Markus Schade 2008-11-28 18:21:06 EST
same on i368

grub-0.97-38.fc10.i386


Output of lspci | grep VGA:
01:00.0 VGA compatible controller: nVidia Corporation GeForce 8600 GT (rev a1)
Comment 2 Samuel Sieb 2008-12-23 00:47:21 EST
I see this on all the computers I've upgraded to F10.
Comment 3 Lloyd Matthews 2009-01-31 11:14:45 EST
I have just had this occur on one of my computers.  The last update with Kernel 
2.6.27.12-170.2.5.fc10.i686 caused GRUB to fail (just a grub prompt when trying to boot).  After a marathon 5 hours of trying to reinstall GRUB, I finally found the trick needed.  When I rebooted, I had this problem.  All the gory details on my odyssey are documented in bug #450143 comment #48.  My other computers which have not needed GRUB to be reinstalled are as they should be.
Comment 4 lexual 2009-03-01 04:46:01 EST
Same here on rawhide.
Comment 5 lexual 2009-03-01 04:55:49 EST

*** This bug has been marked as a duplicate of bug 468865 ***
Comment 6 Markus Schade 2009-03-01 05:42:51 EST
This bug is _not_ a duplicate. A such it must not be closed. The issue here is about grub only displaying the splash behind text. That Fedora 10 doesn't show the grub menu by default is okay, but it will when other OS are installed.
Comment 7 Lloyd Matthews 2009-03-05 10:16:47 EST
I agree, this is NOT the same as #468865.  Up until GRUB failed to install on a
new kernel, I had a splash image behind the first GRUB screen.  That screen is
the one with only the default boot selection shown.  Please re-open this bug.
Comment 8 Samuel Sieb 2009-03-31 23:25:05 EDT
I just did another F10 upgrade from F9.  After the initial upgrade from the DVD, the splash screen displayed on boot (not the menu, just the timeout to boot).  I upgraded the kernel and then ran grub-install (to avoid the GRUB failure I've had on all other upgrades).  I then rebooted and the splash screen only showed up behind the displayed characters, not the full screen.  The only difference was a kernel upgrade and running grub-install.
Comment 9 Kyle 2009-05-04 11:57:28 EDT
This is not a duplicate.  I'm experiencing this with FC11 preview (rawhide).  Please reopen this bug.
Comment 10 Kyle 2009-05-22 11:36:17 EDT
It looks like Bug 499985 is a duplicate of this one, but includes a patch to fix it.  Please get the patch incorporated before FC11 release, if possible.
Comment 11 Kyle 2009-05-22 12:31:38 EDT
After looking at the patch given in Bug 499985 I realized it already appears to be applied in grub-0.97-50.fc11.  Since I was still seeing this problem, I noticed the patch added a new 'grub_verbose' flag.  Once I added 'verbose=0' in my grub.conf I can now see the background image behind the timeout text!

Here's my grub.conf:
default=0
timeout=5
hiddenmenu
splashimage=(hd0,1)/grub/splash.xpm.gz
verbose=0
title Fedora (2.6.29.3-155.fc11.x86_64)
        root (hd0,1)
        kernel /vmlinuz-2.6.29.3-155.fc11.x86_64 ro root=/dev/vg_brownant/lv_root rhgb quiet selinux=0 vga=0x37D
        initrd /initrd-2.6.29.3-155.fc11.x86_64.img
title Fedora (2.6.29.3-140.fc11.x86_64)
        root (hd0,1)
        kernel /vmlinuz-2.6.29.3-140.fc11.x86_64 ro root=/dev/vg_brownant/lv_root rhgb quiet selinux=0 vga=0x37D
        initrd /initrd-2.6.29.3-140.fc11.x86_64.img
title Fedora (2.6.29.2-126.fc11.x86_64)
        root (hd0,1)
        kernel /vmlinuz-2.6.29.2-126.fc11.x86_64 ro root=/dev/vg_brownant/lv_root rhgb quiet selinux=0 vga=0x37D
        initrd /initrd-2.6.29.2-126.fc11.x86_64.img
title WinXP
        rootnoverify (hd0,0)
        chainloader +1
Comment 12 Eelko Berkenpies 2009-05-31 06:14:00 EDT
Created attachment 346004 [details]
 drop in replacement for the existing grub-keystatus.patch

Currently adding verbose=0 to the /boot/grub.conf makes the splash screen work as expected for Fedora 10 and Rawhide.
Comment 13 Eelko Berkenpies 2009-05-31 06:14:50 EDT
*** Bug 499985 has been marked as a duplicate of this bug. ***
Comment 14 Eelko Berkenpies 2009-05-31 06:15:16 EDT
*** Bug 479468 has been marked as a duplicate of this bug. ***
Comment 15 Bug Zapper 2009-06-09 05:57:37 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 16 Lubomir Rintel 2009-06-22 04:52:03 EDT
*** Bug 507063 has been marked as a duplicate of this bug. ***
Comment 17 Jonathan Pritchard 2009-07-17 16:45:40 EDT
I can confirm that I was seeing this still when I installed Fedora 11 on my Thinkpad T400. Using the workaround in Comment #11 fixed the issue.
Comment 18 Colin Simpson 2009-08-15 15:26:20 EDT
I thought it was just me that had this given it's persisted for several releases.
Comment 19 Michal Hlavinka 2009-10-22 07:17:00 EDT
I can confirm this after F-12 Beta installation, in F11 it worked for me well.
Comment 20 Bug Zapper 2009-11-16 04:40:42 EST
This bug appears to have been reported against 'rawhide' during the Fedora 12 development cycle.
Changing version to '12'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 21 Julian Sikorski 2010-01-05 17:32:13 EST
The patch from comment #12 has been incorporated into rawhide grub. It works for me when installed on F-12 (after a grub-install).
Comment 22 Peter Jones 2010-01-05 17:53:11 EST
Should be fixed in grub-0.97-64.fc13 in rawhide.
Comment 23 Julian Sikorski 2010-01-29 18:12:05 EST
It is. I tested this grub on F-12.
Comment 24 Paul Howarth 2010-05-26 11:11:51 EDT
Still broken in RHEL-6 Beta for what it's worth.
Comment 25 Sergio Monteiro Basto 2010-05-26 13:18:15 EDT
Still broken in F13 .
Comment 26 Julian Sikorski 2010-05-26 13:35:08 EDT
Did you upgrade or reinstall? IIRC grub does not get reinstalled during upgrades, and that needs to happen for this bug to get fixed.
Comment 27 Sergio Monteiro Basto 2010-05-26 16:23:48 EDT
(In reply to comment #26)
> Did you upgrade or reinstall?

Upgrade 

> IIRC grub does not get reinstalled during
> upgrades, and that needs to happen for this bug to get fixed.    

What I need to do ? 
grub-install or rpm -e grub && rpm -i grub ?
Comment 28 Julian Sikorski 2010-05-26 17:05:38 EDT
grub-install. Watch out, though, this is a command which might your system not bootable if something goes wrong.
Comment 29 Colin Simpson 2010-05-30 07:46:17 EDT
Works for me in F13
Comment 30 Sergio Monteiro Basto 2010-05-30 21:52:54 EDT
(In reply to comment #28)
> grub-install. Watch out, though, this is a command which might your system not
> bootable if something goes wrong.    

works for me in F13 (also).

Note You need to log in before you can comment on or make changes to this bug.