Bug 479648 - group:lp:rw- permission absent from USB device when hotplugged (HP Deskjet F2280)
group:lp:rw- permission absent from USB device when hotplugged (HP Deskjet F2...
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: hplip (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
: 479660 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-12 06:08 EST by James
Modified: 2009-03-13 14:34 EDT (History)
2 users (show)

See Also:
Fixed In Version: 2.8.12-6.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-13 14:34:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James 2009-01-12 06:08:07 EST
The "group:lp:rw-" permission is absent from the USB device for my HP Deskjet F2280 printer/scanner when hot-plugged. When plugged in on boot, it prints fine. Note that the scanner function of the printer works OK, even when printing doesn't.

The device:
usb 6-1: new full speed USB device using uhci_hcd and address 3
usb 6-1: configuration #1 chosen from 1 choice
usblp0: USB Bidirectional printer dev 3 if 1 alt 0 proto 2 vid 0x03F0 pid
0x2404
usb 6-1: New USB device found, idVendor=03f0, idProduct=2404
usb 6-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 6-1: Product: Deskjet F2200 series
usb 6-1: Manufacturer: HP
usb 6-1: SerialNumber: CN89H4Q0HJ0534

In /var/log/messages:
Jan 12 10:29:46 rhapsody python: io/hpmud/jd.c 84: unable to read device-id
Jan 12 10:29:46 rhapsody python: hp-toolbox(UI)[6976]: error: Unable to
communicate with device (code=12):
hp:/net/HP_LaserJet_4000_Series?ip=137.44.14.164
Jan 12 10:29:46 rhapsody python: hp-toolbox(UI)[6976]: warning: Device not
found
Jan 12 10:30:06 rhapsody Deskjet_F2200_series?serial=CN89H4Q0HJ0534:
io/hpmud/musb.c 135: unable get_string_descriptor -1: Operation not permitted
Jan 12 10:30:06 rhapsody Deskjet_F2200_series?serial=CN89H4Q0HJ0534:
io/hpmud/musb.c 603: invalid product id string ret=-1
Jan 12 10:30:06 rhapsody Deskjet_F2200_series?serial=CN89H4Q0HJ0534:
io/hpmud/musb.c 1104: unable to open
hp:/usb/Deskjet_F2200_series?serial=CN89H4Q0HJ0534
Jan 12 10:30:06 rhapsody Deskjet_F2200_series?serial=CN89H4Q0HJ0534:
prnt/backend/hp.c 679: INFO: open device failed stat=12; will retry in 30
seconds...
Jan 12 10:30:36 rhapsody Deskjet_F2200_series?serial=CN89H4Q0HJ0534:
io/hpmud/musb.c 135: unable get_string_descriptor -1: Operation not permitted
Jan 12 10:30:36 rhapsody Deskjet_F2200_series?serial=CN89H4Q0HJ0534:
io/hpmud/musb.c 603: invalid product id string ret=-1
Jan 12 10:30:36 rhapsody Deskjet_F2200_series?serial=CN89H4Q0HJ0534:
io/hpmud/musb.c 1104: unable to open
hp:/usb/Deskjet_F2200_series?serial=CN89H4Q0HJ0534
Jan 12 10:30:36 rhapsody Deskjet_F2200_series?serial=CN89H4Q0HJ0534:
prnt/backend/hp.c 679: INFO: open device failed stat=12; will retry in 30
seconds...

Permissions:
[root@rhapsody rules.d]# getfacl /dev/bus/usb/006/003 
getfacl: Removing leading '/' from absolute path names
# file: dev/bus/usb/006/003
# owner: root
# group: root
user::rw-
user:james:rw-
group::r--
mask::rw-
other::r--

Of course, if I set these wide open printing starts to work.

Software versions:
hal-0.5.12-12.20081027git.fc10.x86_64
hal-info-20081219-1.fc10.noarch
udev-127-3.fc10.x86_64
hplip-2.8.12-1.fc10.x86_64
cups-1.3.9-6.fc10.x86_64
PolicyKit-0.9-4.fc10.x86_64
Comment 1 Tim Waugh 2009-01-12 08:56:56 EST
*** Bug 479660 has been marked as a duplicate of this bug. ***
Comment 2 Tim Waugh 2009-01-12 08:57:53 EST
*** Bug 478495 has been marked as a duplicate of this bug. ***
Comment 3 James 2009-01-13 17:52:59 EST
I'm now using hplip-2.8.12-5.fc10. The problem seems resolved on my machines, as far as I have tested.
Comment 4 Fedora Update System 2009-01-14 22:05:05 EST
hplip-2.8.12-5.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11236
Comment 5 Adam Goode 2009-01-28 19:06:06 EST
This does not fix the symptoms in bug 478495. Maybe that bug should be unmarked as a duplicate, since this bug is about HOT plugging, and that bug is about COLD plugging.
Comment 6 Fedora Update System 2009-01-29 18:01:40 EST
hplip-2.8.12-6.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update hplip'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2008-11236
Comment 7 Fedora Update System 2009-03-13 14:34:23 EDT
hplip-2.8.12-6.fc10 has been pushed to the Fedora 10 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.