Bug 47969 - Installation aborted
Summary: Installation aborted
Status: CLOSED DUPLICATE of bug 19523
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i686 Linux
medium
medium
Target Milestone: ---
Assignee: Brent Fox
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-07-09 09:22 UTC by Samuel
Modified: 2007-04-18 16:34 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-12 14:55:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Samuel 2001-07-09 09:22:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Hotbar 2.0)

Description of problem:
During installation process, the system prompted for "TypeError: bad 
operand type(s)" after it has created the LoopBack on Device.




How reproducible:
Always

Steps to Reproduce:
1. Followed the installation steps
2.
3.
	

Actual Results:  Installation aborted.


Expected Results:  Installation should have continued.

Additional info:

Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 1030, in 
run
    rc = apply (step[1](), step[2])
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/text.py", line 507, in 
__call__
    if todo.doInstall ():
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1466, in 
doInstall
    self.fstab.makeFilesystems ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/fstab.py", line 664, in 
makeFilesystems
    isys.umount("/mnt/loophost")
  File "/usr/lib/anaconda/isys.py", line 116, in umount
    mountCount[what] = mountCount - 1
TypeError: bad operand type(s) for -

Local variables in innermost frame:
what: /mnt/loophost
removeDir: 1

ToDo object:
(itodo ToDo
p1
(dp2 S'method'
p3
(iimage CdromInstallMethod
p4
(dp5 S'progressWindow'
p6
<failed>

Comment 1 Matt Wilson 2001-07-12 14:55:33 UTC
I have never seen this error before.  Please try booting your system with "linux
ide=nodma".  If that fixes your problem, run:

for I in /proc/ide/hd*; do echo $I; cat $I/model; done 

on your installed system and attach the results here.


Comment 2 Brent Fox 2001-07-25 16:08:40 UTC
This is a dupe of bug #19523.  An updates disk is available at
ftp://people.redhat.com/ewt/mountupd.img.gz



*** This bug has been marked as a duplicate of 19523 ***


Note You need to log in before you can comment on or make changes to this bug.