Bug 479712 - (ffrightclick) right-click mouse menu randomly selects like whatever ...
right-click mouse menu randomly selects like whatever ...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xulrunner (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Martin Stransky
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-12 11:39 EST by Matěj Cepl
Modified: 2018-04-11 07:18 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-25 04:00:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 404314 None None None Never
Mozilla Foundation 406646 None None None Never

  None (edit)
Description Matěj Cepl 2009-01-12 11:39:22 EST
Description of problem:
When clicking right-click mouse menu, quite often random item in the menu is selected. Given that I have never seen the behavior outside of Firefox/Thunderbird, and that I heard many complaints about it from people with random hardware architectures I blame XULRunner & co.

Version-Release number of selected component (if applicable):
firefox-3.0.5-1.fc10.i386
thunderbird-2.0.0.19-1.fc10.i386
xulrunner-1.9.0.5-1.fc10.i386
(but observed in wild since sometime deep in F10 development cycle)

How reproducible:
Randomly happens

Steps to Reproduce:
1.right-click with mouse
2.
3.
  
Actual results:
quite often instead of showing menu something random is selected

Expected results:
just showing the menu

Additional info:
Comment 1 Matěj Cepl 2009-01-12 11:48:00 EST
IMHO, for example bug 477738 is just representation of this one.
Comment 2 Matěj Cepl 2009-01-12 11:49:19 EST
(In reply to comment #1)
> IMHO, for example bug 477738 is just representation of this one.

sorry, wrong tab -- I meant bug 477742
Comment 4 Caolan McNamara 2009-03-19 10:01:49 EDT
Patch apparently now available upstream
Comment 5 Matěj Cepl 2009-03-25 04:00:34 EDT
Looks like (hopefully) https://bugzilla.mozilla.org/attachment.cgi?id=367643 (for 1.9.1) and https://bugzilla.mozilla.org/attachment.cgi?id=367667 (for 1.9.0) are fixes.

Red Hat will continue to track the issue in the centralized upstream bug tracker, and will review any bug fixes that become available for consideration in future updates.

Thank you for the bug report.

Note You need to log in before you can comment on or make changes to this bug.