This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 479790 - mic in not working and no controls to switch exposed
mic in not working and no controls to switch exposed
Status: CLOSED DUPLICATE of bug 491372
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-12 22:56 EST by Rudolf Kastl
Modified: 2009-04-03 12:22 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-04-03 12:22:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Rudolf Kastl 2009-01-12 22:56:33 EST
Description of problem:
on a dell d620 and an x200 (ich7 and ich9) i cant figure a way to enable the microphone in jack. both are using snd-hda-intel. internal microphone on the d620 works fine. i am not sure if alsa or pulseaudio is responsible. if necassery please reassign.
the internal mic of the d620 is the default capture device and works (although it is not very loud)


outut of alsa-info on the dell d620:
http://www.alsa-project.org/db/?f=5ccc609a2786a6f1032a267a219289f079098d26

Version-Release number of selected component (if applicable):
pulseaudio-0.9.13-7.fc11.i386

How reproducible:
always

Steps to Reproduce:
1. try to use gnome-volume-manager or alsactl to change capture to front mic
2. while alsa-info shows it i cant find a way to switch
  
Actual results:
no working mic in

Expected results:
working mic in

Additional info:
just ask
Comment 1 Roland Roberts 2009-01-29 13:31:55 EST
I have the same problem on a Dell Latitude D820, first reported in https://bugzilla.redhat.com/show_bug.cgi?id=477888.

I had been using a line-in, powered stereo microphone under Fedora 8.  I upgraded from 8 -> 9 -> 10 (did not test at 9, only upgraded as part of the upgrade to 10) and lost sound.  Bug 477888 resolve output issues, but the input selection does not work.

My alsa-info.sh output is at 
http://www.alsa-project.org/db/?f=084c6a31097b4dd2a7d6a963c36ea6064b16695e
Comment 2 Rudolf Kastl 2009-02-13 00:59:43 EST
it would be nice to get points what to do next to get the issues resolved.
Comment 3 Matthias Clasen 2009-02-20 16:36:23 EST
The intended way to switch sound input devices is the device list on the input tab of the sound capplet. 

Does that not work ?
Comment 4 Roland Roberts 2009-02-20 22:07:02 EST
After a bit more research, I seem to be able to select between the built-in microphone and the microphone jack.  I am offered two choices: "Mic" and "Front Mic".  I have lost the Line-in choice that Fedora 8 had/.
Comment 5 Lennart Poettering 2009-04-03 12:22:47 EDT

*** This bug has been marked as a duplicate of bug 491372 ***

Note You need to log in before you can comment on or make changes to this bug.