Bug 479816 - ~/.gvfs Permission denied
~/.gvfs Permission denied
Status: CLOSED DUPLICATE of bug 447314
Product: Fedora
Classification: Fedora
Component: gvfs (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-13 06:01 EST by Mark Watts
Modified: 2009-06-23 05:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-06-23 05:07:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Watts 2009-01-13 06:01:59 EST
Description of problem:

# cd /home/user
# ls -la | grep .gvfs
ls: cannot access .gvfs: Permission denied
d?????????  ? ?      ?               ?                ? .gvfs


Version-Release number of selected component (if applicable):
Fedora 10

How reproducible:
Only seen on this system.

Steps to Reproduce:
1. Unknown - appeared after first boot after install.
  
Actual results:
I'm not sure whether this is causing any problems as such, but I'm nto sure what its function is.

I can't delete it, move it or rename it because it doesn't appear to have any valid permissions/ownership.

Expected results:
I believe this file/directory should have sane permissions and ownership.


Additional info:
Filesystem is ext3 on a LUKS encrypted LVM partition (all of / apart from /boot is encrypted).
Comment 1 Joost Ruijsch 2009-06-19 16:17:03 EDT
I think this is same bug as Bug 503956.
It happens when you disable the netfs service.
Comment 2 Tomáš Bžatek 2009-06-23 05:07:13 EDT
This is a designed behaviour of the fuse filesystem, restricted to the originator user, denying access to everyone else, including root. Please see similar bug 435620 and bug 447314.

Bug 503956 is a different issue and is being solved in bug 493565.

*** This bug has been marked as a duplicate of bug 447314 ***

Note You need to log in before you can comment on or make changes to this bug.