Bug 479916 - gnome-media does not handle gnome-volume-control-applet properly
gnome-media does not handle gnome-volume-control-applet properly
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gnome-applets (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-13 19:11 EST by Michal Jaegermann
Modified: 2009-03-07 01:02 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-03-07 01:02:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2009-01-13 19:11:21 EST
Description of problem:

I was asked to file that in bug 479495#c4.

I can find in "Properties" of "Sessions" that gnome-volume-control-applet is on a list of gnome-session programs.  It indeed shows up on a list of running processes and in ~/.xsession-errors there is a bunch of lines with a debug output from it.  Say:

** (gnome-volume-control-applet:2897): DEBUG: Updating source: index=0 name='alsa_output.pci_1106_3059_sound_card_0_alsa_playback_0.monitor' description='Monitor of VIA 8237 - VIA 8237'
** (gnome-volume-control-applet:2897): DEBUG: Updating source: index=1 name='alsa_input.pci_1106_3059_sound_card_0_alsa_capture_0' description='VIA 8237 - VIA 8237'

That does not mean that anything related to it shows up on my panel or other menus.  I can run gnome-volume control from a terminal window, which gives
me only one choice for an input and output device, namely 'VIA 8237 - VIA 8237', but that is about it.

OTOH on an "Add to Panel" list the only related thing which shows up is "Volume Control (Deprecated)" and attempts to add it back to a panel are rejected.  According to quoted comment this is because "it wasn't null-appletified properly" (whatever that is trying to say).

Version-Release number of selected component (if applicable):
gnome-media-2.25.1-4.fc11.x86_64
Comment 1 Bastien Nocera 2009-01-19 12:38:09 EST
Do you have a "notification area" applet added to your panel? It should show up as a speaker icon.
Comment 2 Michal Jaegermann 2009-01-19 15:22:10 EST
No, I did not have a "notification area" there, nothing added it automatically, I did not guess that this may anything to do with a sound.  After adding it explicitely  indeed a speaker icon did show up.

OTOH "Volume control (deprecated)" is still present on "Add to panel" list.

I can only hope that these new volume controls will work somehow.  On a new "from scratch" Fedora 10 installation changing volume was shifting only between totally
inaudible to something which was barely making you aware that something is indeed there with master volume at the max.  That until I tried some other controls.
Comment 3 Bastien Nocera 2009-01-20 05:09:36 EST
The notification area applet can show more than just the volume control. That's where PackageKit will tell you updates are available, or Pidgin put its status icon.

Reassigning to gnome-applets, I believe the fact that the Volume control still shows up in "add to panel" has been fixes in SVN trunk.
Comment 4 Matthias Clasen 2009-03-07 01:02:52 EST
the volume control applet does no longer show up in the 'add to panel' list.

Note You need to log in before you can comment on or make changes to this bug.