Bug 479947 - remove dependency on bluez-gnome
remove dependency on bluez-gnome
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
: 500203 (view as bug list)
Depends On:
Blocks: FedoraServerTracker
  Show dependency treegraph
 
Reported: 2009-01-14 03:53 EST by Daniel Mach
Modified: 2009-05-13 10:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-14 11:32:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Daniel Mach 2009-01-14 03:53:23 EST
bluez requires bluez-gnome (dbus-bluez-pin-helper is needed by package bluez)
This dependency pulls a lot of x11 and gnome packages in @base group installation.

Do you think this dependency can be removed or somehow fixed to avoid x11 deps in @base comps group?
Comment 1 Bastien Nocera 2009-01-14 11:32:47 EST
Yes, it could be fixed by someone writing a command-line passkey agent and setup wizard. Bluez requires a passkey agent to provide back and forth for the PIN helper (eg. a "dbus-bluez-pin-helper").

Removing the dependency is out of the question.
Comment 2 Bastien Nocera 2009-05-13 10:45:44 EDT
*** Bug 500203 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.