Bug 500203 - Set default Runlevel to 3 when no X-Server is installed
Set default Runlevel to 3 when no X-Server is installed
Status: CLOSED DUPLICATE of bug 479947
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-05-11 13:02 EDT by Markus Mayer
Modified: 2014-01-21 18:04 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-05-13 10:45:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Markus Mayer 2009-05-11 13:02:38 EDT
Description of problem:


Version-Release number of selected component (if applicable): 
anaconda 11.5.0.47

How reproducible:


Steps to Reproduce:
1. Install Fedora 11
2. Deselect every Package-Group exept Basesystem/Base
3. finish installation
  
Actual results:
Even there is no X-Server installed the default runlevel is set to 5 (X11). This causes that no login-promt will be displayed on tty1

Expected results:
When no X-Server is installed to default runlevel should be set to 3.
Comment 1 Chris Lumens 2009-05-11 13:17:19 EDT
What are the results of rpm -q --whatprovides service(graphical-login) ?
Comment 2 Markus Mayer 2009-05-12 02:00:32 EDT
(In reply to comment #1)
> What are the results of rpm -q --whatprovides service(graphical-login) ?  

rpm -q --whatprovides service
no package provides service

rpm -q --whatprovides graphical-login
no package provides graphical-login
Comment 3 Markus Mayer 2009-05-12 05:44:44 EDT
(In reply to comment #2)
> (In reply to comment #1)
> > What are the results of rpm -q --whatprovides service(graphical-login) ?  
> 
> rpm -q --whatprovides service
> no package provides service
> 
> rpm -q --whatprovides graphical-login
> no package provides graphical-login  


rpm -q --whatprovides "service(graphical-login)" returns:
kdm-4.2.2-5.fc11.i586
Comment 4 Chris Lumens 2009-05-12 10:17:28 EDT
Then some package you are installing is pulling in kdm, which provides service(graphical-login), which is what we look for when determining how to set the default runlevel.  Since you deselected everything, this sounds like a problem in the basic minimal package set.
Comment 5 Markus Mayer 2009-05-12 11:46:14 EDT
Here are the results of some further testing:

rpm -q --whaterequires "service(graphical-login)" returns:
no package provides service(graphical-login)

rpm -q --whaterequires kdm returns:
kdebase-workspace

rpm -q --whaterequires kdebase-workspace returns:
kdebase-workspace-libs

rpm -q --whaterequires kdebase-workspace-libs returns:
kdebase-workspace

I will do a new installation and will check which packages are selected in the Basesystem/Base packagegroup.
Comment 6 Markus Mayer 2009-05-13 08:05:03 EDT
Now I know the reason why kdm is installed. It is bluez (that is selected by default in the Basesystem/Base packagegroup).

The dependencies are the following:
bluez requires dbus-bluez-pin-helper
dbus-bluez-pin-helper will be provided by kdebluetooth
kdebluetooth requires some packages provided by kdebase-workspace-libs
kdebase-workspace-libs requires kdebase-workspace
kdebase-workspace requires kdm
kdm provides service(graphical-login)


I have reinstalled Fedora 11 without bluez (all other setting are the same as mentioned above) and now the default runlevel is 3 (like expected). When I try to install bluez, the package kdm will be installed for depency.

In my opinion this should by fixed. This could by done either by changing the depencies of bluez or by not installing bluez by default.
Comment 7 Bill Nottingham 2009-05-13 09:49:07 EDT
Bastien - is this something that can be changed in bluez?

If you start the daemon without a desktop env started at the time, what happens with respect to pairing, anyway?
Comment 8 Bastien Nocera 2009-05-13 10:19:39 EDT
(In reply to comment #7)
> Bastien - is this something that can be changed in bluez?

You could also install gnome-bluetooth. I guess yum drags the dependency with the shortest name, as it has no way to know which one should be installed.

> If you start the daemon without a desktop env started at the time, what happens
> with respect to pairing, anyway?  

It just won't work.

People have mentioned this sort of problems in the past, and the solution was for someone to write a text-mode pairing interface, which could be installed instead of one of the graphical utilities. Nobody seemed bothered enough.
Comment 9 Bastien Nocera 2009-05-13 10:45:44 EDT

*** This bug has been marked as a duplicate of bug 479947 ***
Comment 10 Daniel Mach 2009-05-13 11:41:09 EDT
If bluez doesn't work without X, why don't we remove bluez from @base comps group and move it to a different group (@gnome-desktop, for example)?
Comment 11 Bill Nottingham 2009-05-13 12:23:59 EDT
Just did that, actually.b

Note You need to log in before you can comment on or make changes to this bug.