Bug 480106 - Banshee needs to depends on mono-addins
Banshee needs to depends on mono-addins
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: banshee (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Michel Alexandre Salim
Fedora Extras Quality Assurance
:
: 481208 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-14 22:26 EST by David Nielsen
Modified: 2009-02-21 08:51 EST (History)
5 users (show)

See Also:
Fixed In Version: banshee-1.4.2-1.fc10
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-02-21 08:51:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2009-01-14 22:26:34 EST
Description of problem:

Without mono-addins banshee throws this nice error on startup.

david@dawkins:~$ banshee-1 --debug
** Running Mono with --debug   **

** (/usr/lib64/banshee-1/Banshee.exe:3702): WARNING **: Symbol file /usr/lib64/mono/gac/NDesk.DBus/1.0.0.0__f6716e4f9b2ed099/NDesk.DBus.dll.mdb has incorrect version (expected 50.0, got 39)
[Info  04:20:26.245] Running Banshee 1.4.1

** (/usr/lib64/banshee-1/Banshee.exe:3702): WARNING **: The following assembly referenced from /usr/lib64/banshee-1/Banshee.Services.dll could not be loaded:
     Assembly:   Mono.Addins    (assemblyref_index=7)
     Version:    0.3.0.0
     Public Key: 0738eb9f132ed756
The assembly was not found in the Global Assembly Cache, a path listed in the MONO_PATH environment variable, or in the location of the executing assembly (/usr/lib64/banshee-1).


** (/usr/lib64/banshee-1/Banshee.exe:3702): WARNING **: Could not load file or assembly 'Mono.Addins, Version=0.3.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756' or one of its dependencies.

** (/usr/lib64/banshee-1/Banshee.exe:3702): WARNING **: Could not load file or assembly 'Mono.Addins, Version=0.3.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756' or one of its dependencies.

** (/usr/lib64/banshee-1/Banshee.exe:3702): WARNING **: Missing method GetExtensionNodes in assembly /usr/lib64/banshee-1/Banshee.Services.dll, type Mono.Addins.AddinManager
Exception has been thrown by the target of an invocation.
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.TypeLoadException: Could not load type 'Banshee.ServiceStack.ServiceManager' from assembly 'Banshee.Services, Version=1.4.0.0, Culture=neutral, PublicKeyToken=null'.
  at Banshee.ServiceStack.Application.Initialize () [0x00005] in /builddir/build/BUILD/banshee-1-1.4.1/src/Core/Banshee.Services/Banshee.ServiceStack/Application.cs:77 
  at Banshee.Gui.GtkBaseClient.Initialize (Boolean registerCommonServices) [0x0000a] in /builddir/build/BUILD/banshee-1-1.4.1/src/Core/Banshee.ThickClient/Banshee.Gui/GtkBaseClient.cs:99 
  at Banshee.Gui.GtkBaseClient..ctor (Boolean initializeDefault, System.String defaultIconName) [0x00013] in /builddir/build/BUILD/banshee-1-1.4.1/src/Core/Banshee.ThickClient/Banshee.Gui/GtkBaseClient.cs:90 
  at Banshee.Gui.GtkBaseClient..ctor () [0x00000] in /builddir/build/BUILD/banshee-1-1.4.1/src/Core/Banshee.ThickClient/Banshee.Addins.Gui/AddinDetailsDialog.cs:1 
  at Nereid.Client..ctor () [0x00000] in /builddir/build/BUILD/banshee-1-1.4.1/src/Clients/Nereid/Nereid/Client.cs:1 
  at (wrapper managed-to-native) System.Reflection.MonoCMethod:InternalInvoke (object,object[],System.Exception&)
  at System.Reflection.MonoCMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00074] in /builddir/build/BUILD/mono-2.0.1/mcs/class/corlib/System.Reflection/MonoMethod.cs:426 
  --- End of inner exception stack trace ---
  at System.Reflection.MonoCMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00086] in /builddir/build/BUILD/mono-2.0.1/mcs/class/corlib/System.Reflection/MonoMethod.cs:432 
  at System.Reflection.MonoCMethod.Invoke (BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[] parameters, System.Globalization.CultureInfo culture) [0x00000] in /builddir/build/BUILD/mono-2.0.1/mcs/class/corlib/System.Reflection/MonoMethod.cs:441 
  at System.Reflection.ConstructorInfo.Invoke (System.Object[] parameters) [0x0000e] in /builddir/build/BUILD/mono-2.0.1/mcs/class/corlib/System.Reflection/ConstructorInfo.cs:77 
  at System.Activator.CreateInstance (System.Type type, Boolean nonPublic) [0x00083] in /builddir/build/BUILD/mono-2.0.1/mcs/class/corlib/System/Activator.cs:320 
  at System.Activator.CreateInstance (System.Type type) [0x00000] in /builddir/build/BUILD/mono-2.0.1/mcs/class/corlib/System/Activator.cs:213 
  at Banshee.Gui.GtkBaseClient.Startup () [0x00000] in /builddir/build/BUILD/banshee-1-1.4.1/src/Core/Banshee.ThickClient/Banshee.Gui/GtkBaseClient.cs:77 
  at Hyena.Gui.CleanRoomStartup.Startup (Hyena.Gui.StartupInvocationHandler startup) [0x00048] in /builddir/build/BUILD/banshee-1-1.4.1/src/Libraries/Hyena.Gui/Hyena.Gui/CleanRoomStartup.cs:54 


Version-Release number of selected component (if applicable):
banshee-1.4.1-4.fc10.x86_64

How reproducible:
100%

Steps to Reproduce:
1. yum install banshee
2. banshee-1
  
Actual results:
as above

Expected results:
running banshee goodness

Additional info:
x86_64, da_DK.UTF-8
Comment 1 Šimon Lukašík 2009-01-20 16:44:40 EST
Same result
Comment 2 Šimon Lukašík 2009-01-20 16:56:59 EST
Sorry, It's typo. I just want to CC myself, but I forget to blank comment box.
Comment 3 Fedora Update System 2009-01-26 20:52:44 EST
banshee-1.4.2-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update banshee'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2009-1007
Comment 4 Fedora Update System 2009-01-26 20:55:59 EST
banshee-1.4.2-1.fc10 has been pushed to the Fedora 10 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update banshee'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F10/FEDORA-2009-1051
Comment 5 Paul Lange 2009-01-27 16:33:12 EST
*** Bug 481208 has been marked as a duplicate of this bug. ***
Comment 6 David Nielsen 2009-02-21 08:51:04 EST
banshee-1.4.2-1.fc10 is now in stable. 

https://admin.fedoraproject.org/updates/F10/FEDORA-2009-1051

However bodhi has not updated the bug

Note You need to log in before you can comment on or make changes to this bug.