Bug 480377 - Can't read Exchange mail in Evolution
Can't read Exchange mail in Evolution
Status: CLOSED DUPLICATE of bug 480123
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
10
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-16 14:09 EST by Matthew Saltzman
Modified: 2009-01-16 15:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-16 15:59:22 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Saltzman 2009-01-16 14:09:56 EST
Description of problem:
Evolution with an active Exchange account crashes on startup using this version of evolution-data-server (currently in updates-testing).

Version-Release number of selected component (if applicable):
evolution-data-server-2.24.3-1.fc10 

How reproducible:
Always

Steps to Reproduce:
1. Have an active Exchange account in Evolution
2. Update Evolution from updates-testing
3. Start Evolution
  
Actual results:
Starting from a command line produces the following messages and Evo hangs or crashes:

--------------------------------------------------
$ evolution
 
[...blank lines elided...]
 
RSS Plugin enabled (evolution 2.24, evolution-rss 0.1.2)
** (evolution:30063): DEBUG: mailto URL command: evolution --component=mail %s
** (evolution:30063): DEBUG: mailto URL program: evolution

(evolution:30063): camel-WARNING **: camel_type_register: 'CamelExchangeFolder' has smaller class size than parent 'CamelOfflineFolder'

(evolution:30063): camel-CRITICAL **: camel_object_is: assertion `o != NULL' failed

(evolution:30063): camel-CRITICAL **: camel_folder_construct: assertion `CAMEL_IS_FOLDER (folder)' failed
-------------------------------------------------


Expected results:
Evolution works as usual.

Additional info:

I upgraded all Evolution packages to updates-testing, then observed the failure.  I downgraded all Evo packages to those in updates, but accidentally failed to downgrade evolution-data-server.  Still observed the problem.  I downgraded evolution-data-server to the version in updates and the problem disappeared.  (Hence the choice to file under this component.)  The current version in updates is evolution-data-server-2.24.2-1.fc10.
Comment 1 Matthew Barnes 2009-01-16 15:59:22 EST

*** This bug has been marked as a duplicate of bug 480123 ***

Note You need to log in before you can comment on or make changes to this bug.