This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 480233 - ISE generated when deleting a System->Stored Profile
ISE generated when deleting a System->Stored Profile
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: WebUI (Show other bugs)
0.4
All Linux
low Severity medium
: ---
: ---
Assigned To: Brad Buckingham
Jesus M. Rodriguez
:
: 482883 (view as bug list)
Depends On:
Blocks: space05
  Show dependency treegraph
 
Reported: 2009-01-15 14:53 EST by Brad Buckingham
Modified: 2009-09-17 03:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-09-17 03:09:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ISE data from catalina.out (9.83 KB, application/octet-stream)
2009-01-15 14:53 EST, Brad Buckingham
no flags Details

  None (edit)
Description Brad Buckingham 2009-01-15 14:53:51 EST
Created attachment 329134 [details]
ISE data from catalina.out

Description of problem:

Attempting to delete a system stored profile using the UI generates an ISE.  See attachment for ISE.

Version-Release number of selected component (if applicable):


How reproducible:
Always.  I'm seeing it consistently w/spacewalk-java-0.4.14-1.el5.

Steps to Reproduce:
1. Create a stored profile (Systems->System->Software->Packages->Profile->CreateSystemProfile
2. Attempt to delete the profile (Systems->Stored Profile-> <profile> -> delete profile
3.
  
Actual results:
ISE generated when user attempt to confirm the delete from the confirmation page. (e.g. https://<server>/rhn/profiles/Delete.do?prid=2)

Expected results:
Stored profile deleted.

Additional info:
Comment 1 Brad Buckingham 2009-01-15 17:14:56 EST
It appears that the hibernate mapping for the Profile -> ProfileEntry is incomplete.  The ProfileEntry contains the mapping for each package which includes things like name, evr, arch...etc.   In this case, it appears to be missing the arch; therefore, in profiles where there are multiple packages with different arch, Hibernate generates this exception.  Adding the arch to the mapping should address the issue.
Comment 2 Brad Buckingham 2009-01-16 10:28:22 EST
Modifications made in master w/commit: 17d9fdabd461dd67df887df77009774a5ee7be2b
Comment 3 Brad Buckingham 2009-03-10 17:59:26 EDT
*** Bug 482883 has been marked as a duplicate of this bug. ***
Comment 4 Jesus M. Rodriguez 2009-04-14 10:12:13 EDT
Spacewalk 0.5 released.
Comment 5 Miroslav Suchý 2009-09-17 03:09:06 EDT
Spacewalk 0.5 has been released for long time ago.

Note You need to log in before you can comment on or make changes to this bug.