Bug 480512 - fontconfig - fc-cache refuses to write caches
fontconfig - fc-cache refuses to write caches
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: fontconfig (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
Fedora Extras Quality Assurance
:
: 480669 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-17 19:37 EST by Michal Jaegermann
Modified: 2009-01-19 21:50 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-19 17:24:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fix (633 bytes, patch)
2009-01-18 02:16 EST, Yanko Kaneti
no flags Details | Diff

  None (edit)
Description Michal Jaegermann 2009-01-17 19:37:33 EST
Description of problem:

The latest rawhide updates on my system brought the following fonts:

bitstream-vera-sans-fonts
bitstream-vera-sans-mono-fonts
bitstream-vera-serif-fonts
dejavu-lgc-sans-fonts
dejavu-lgc-sans-mono-fonts
dejavu-lgc-serif-fonts
dejavu-sans-fonts
dejavu-sans-mono-fonts
dejavu-serif-fonts

With every of those packages I got a message like this:

/usr/share/fonts/dejavu: failed to write cache

It turns out that messages are coming from /usr/bin/fc-cache and running '/usr/bin/fc-cache -v /usr/share/fonts/dejavu' produces the following:

/usr/share/fonts/dejavu: caching, new cache contents: 42 fonts, 0 dirs
/usr/share/fonts/dejavu: failed to write cache
/var/cache/fontconfig: cleaning cache directory
/root/.fontconfig: not cleaning non-existent cache directory
/usr/bin/fc-cache: failed

Check with strace reveals what follows:

open("/var/cache/fontconfig/12b26b760a24f8b4feb03ad48a333a72-x86-64.cache-2", O_
RDONLY) = -1 ENOENT (No such file or directory)
open("/root/.fontconfig/12b26b760a24f8b4feb03ad48a333a72-x86-64.cache-2", O_RDON
LY) = -1 ENOENT (No such file or directory)
write(2, "/usr/share/fonts/dejavu: failed t"..., 47) = 47
unlink("/var/cache/fontconfig/12b26b760a24f8b4feb03ad48a333a72-x86-64.cache-2") 
= -1 ENOENT (No such file or directory)
unlink("/root/.fontconfig/12b26b760a24f8b4feb03ad48a333a72-x86-64.cache-2") = -1
 ENOENT (No such file or directory)

Attempts to open new files with O_RDONLY?  I do not think that this is going to work.

Version-Release number of selected component (if applicable):
fontconfig-2.6.90-3.git.63.g6bb4b9a.fc11.x86_64

How reproducible:
On every try.
Comment 1 Yanko Kaneti 2009-01-18 02:16:55 EST
Created attachment 329296 [details]
fix
Comment 2 Nicolas Mailhot 2009-01-19 14:18:48 EST
*** Bug 480669 has been marked as a duplicate of this bug. ***
Comment 3 Behdad Esfahbod 2009-01-19 17:24:23 EST
Will hit rawhide tomorrow.

Note You need to log in before you can comment on or make changes to this bug.