Bug 480581 - User Access:Can create a non-name user
User Access:Can create a non-name user
Status: CLOSED DUPLICATE of bug 478724
Product: Virtualization Tools
Classification: Community
Component: ovirt-server-suite (Show other bugs)
unspecified
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Hugh Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-19 04:49 EST by Jia Dong
Modified: 2010-03-16 13:17 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-21 02:50:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jia Dong 2009-01-19 04:49:25 EST
Description of problem:
A non-name user can be created. 

Version-Release number of selected component (if applicable):
0.96

How reproducible:
Every time

Steps to Reproduce:
1.Click "default" hardware pool.
2.Click "User Access" tab.
3.Click "Add user" button
4.Select one role in popped dialog and click "Create User Permission“ button.
5.Click "Add user" button
6.Select one role in popped dialog and click "Create User Permission“ button.
7.Click "Add user" button
8.Select one role in popped dialog and click "Create User Permission“ button.
  
Actual results:
After step5,a null user name is listed in the list.
After step6,a non-name user has been created.
After step8,it prompt "Error Adding User:Validation failed:Uid has already been taken".


Expected results:
The null id can not be used.
User can specify user name or provide an interface for users to specify other members.

Additional info:
Comment 1 Jia Dong 2009-01-21 02:50:57 EST

*** This bug has been marked as a duplicate of bug 478724 ***

Note You need to log in before you can comment on or make changes to this bug.