Bug 480668 - start cups on demand using systemd
start cups on demand using systemd
Status: CLOSED DUPLICATE of bug 690766
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-19 13:59 EST by Bill Nottingham
Modified: 2014-03-16 23:17 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-07 04:29:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
cups changes required (10.99 KB, patch)
2009-01-19 13:59 EST, Bill Nottingham
no flags Details | Diff
xinetd service file (294 bytes, text/plain)
2009-01-19 14:00 EST, Bill Nottingham
no flags Details
SELinux policy module (241 bytes, text/plain)
2009-01-19 14:01 EST, Bill Nottingham
no flags Details

  None (edit)
Description Bill Nottingham 2009-01-19 13:59:35 EST
Created attachment 329383 [details]
cups changes required

Description of problem:

(Filing for completeness sake - have already talked a bit with Tim about this over e-mail)

Looking at cups, it has code to start on demand via launchd when a connection attempt is made to the cups socket address. It's possible to use a similar mechanism to start cups on demand via xinetd, so it can be started on demand instead of always running.

Open issues:
- you trade starting cups always for starting xinetd always
- you need to do 'something' for when you share printers
- the xinetd file requires lockstep agreement with any 'Listen' statements in cupsd.conf

Version-Release number of selected component (if applicable):

cups-1.4-0.b2.2
Comment 1 Bill Nottingham 2009-01-19 14:00:27 EST
Created attachment 329384 [details]
xinetd service file
Comment 2 Bill Nottingham 2009-01-19 14:01:19 EST
Created attachment 329385 [details]
SELinux policy module

SELinux policy requires changes for cups to work when it's launched from xinetd so that it can properly handle the socket it's passed.
Comment 3 Harald Hoyer 2009-01-28 08:11:15 EST
ping?
Comment 4 Tim Waugh 2009-01-28 09:03:25 EST
Busy with more pressing stuff at the moment...
Comment 5 Tim Waugh 2009-05-15 07:49:02 EDT
Too risky a change until 1.4 has settled down a lot more.
Comment 6 Bug Zapper 2009-06-09 06:47:44 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 11 development cycle.
Changing version to '11'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 7 Adel Gadllah 2009-12-29 07:17:27 EST
(In reply to comment #5)
> Too risky a change until 1.4 has settled down a lot more.  

ping?
Comment 8 Tim Waugh 2010-04-21 07:18:50 EDT
This will be a *lot* easier to do once mDNS is the default discovery and browse mechanism in CUPS.  That won't be until CUPS 1.5 though.

The basic problem is that if cupsd is not around to hear CUPS Browse packets it might be a long time (minutes) after cupsd is started before they are re-sent.  So the user might be sat in front of a print dialog for several minutes before they can get on with printing.

With mDNS this would not be a problem as avahi would be already be doing the listening.
Comment 9 Bill Nottingham 2011-05-09 10:46:36 EDT
Tim - given systemd, should this bug be closed in favor of a systemd implementation, or at least retitled/retargeted?
Comment 10 Tim Waugh 2011-05-13 06:43:41 EDT
Yes, retitling.  We are fairly close to full Bonjour support now, and Lennart has told me he has patches for systemd integration in cupsd.
Comment 11 Juha Tuomala 2011-06-06 14:09:15 EDT
possible duplicate bug 690766
Comment 12 Tim Waugh 2011-06-07 04:29:24 EDT

*** This bug has been marked as a duplicate of bug 690766 ***

Note You need to log in before you can comment on or make changes to this bug.