Bug 690766 - Providing native systemd file for upcoming F15 Feature Systemd
Providing native systemd file for upcoming F15 Feature Systemd
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
: 480668 714434 (view as bug list)
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-03-25 07:02 EDT by Jóhann B. Guðmundsson
Modified: 2011-06-29 12:22 EDT (History)
8 users (show)

See Also:
Fixed In Version: cups-1.5-0.9.rc1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-06-29 12:22:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Native systemd service file (454 bytes, text/plain)
2011-03-25 07:02 EDT, Jóhann B. Guðmundsson
no flags Details
Native cups systemd service file with socket (494 bytes, text/plain)
2011-03-25 12:44 EDT, Jóhann B. Guðmundsson
no flags Details
Native cups systemd socket file. (136 bytes, text/plain)
2011-03-25 12:45 EDT, Jóhann B. Guðmundsson
no flags Details
Minor fixes to the cups service (509 bytes, text/plain)
2011-05-02 14:07 EDT, Jóhann B. Guðmundsson
no flags Details
Minor fixes to the cups socket (153 bytes, text/plain)
2011-05-02 14:09 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-03-25 07:02:15 EDT
Created attachment 487523 [details]
Native systemd service file

Description of problem:

Is it not better to have a native systemd service file for cups before the printing test day ;) 

The attached file is a native systemd file for upcoming F15 Feature [1]

Please read [2] on how to packaging and installing systemd Service files.

To learn more about Systemd daemon see [3].

To view old SysV with the new Systemd site by site see for your component see
[4]

If you have any question dont hesitate to ask them on this bug report.

1.http://fedoraproject.org/wiki/Features/systemd

2.https://fedoraproject.org/wiki/Systemd_Packaging_Draft

3.http://0pointer.de/public/systemd-man/daemon.html

4.https://fedoraproject.org/wiki/User:Johannbg/QA/Systemd/compatability 



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Tim Waugh 2011-03-25 12:16:26 EDT
Should there also be a cups.socket file to describe the UNIX domain socket?

I think I remember Lennart saying that he had patches for CUPS...
Comment 2 Jóhann B. Guðmundsson 2011-03-25 12:44:41 EDT
Created attachment 487602 [details]
Native cups systemd service file with socket
Comment 3 Jóhann B. Guðmundsson 2011-03-25 12:45:59 EDT
Created attachment 487603 [details]
Native cups systemd socket file.
Comment 4 Lennart Poettering 2011-03-29 15:58:44 EDT
Yupp, I have patches. Need to clean them up and submit. CUPS uses copyright assignment iirc, right? was too lazy so far figuring out how this is handled for patches for RH employees. 

Tim, how does that work? Should those patches go through you?
Comment 5 Tim Waugh 2011-03-31 06:35:39 EDT
You can send them to me and I'll try to get them upstream, yes.
Comment 6 Bill Nottingham 2011-04-26 13:35:36 EDT
Moving systemd service RFEs to rawhide.

At this point, it is not appropriate in the Fedora 15 cycle to add these. Furthermore, at this point, we are still finalizing the packaging guidelines to handle SysV -> systemd upgrades.

We therefore request:
- wait until there are packaging guidelines (this will be announced on the devel list). This ensures that upgrades will work smoothly and we/you won't have to do multiple sets of changes.
- work on these sorts of changes for Fedora 16 where necessary, not Fedora 15, as we're trying to fix things for release.
- do *not* change a service from SysV to systemd in an existing release (such as Fedora 15), as this is the sort of behavior change that goes against our update policy, documented as https://fedoraproject.org/wiki/Updates_Policy
Comment 7 Jóhann B. Guðmundsson 2011-05-02 14:07:49 EDT
Created attachment 496324 [details]
Minor fixes to the cups service

Added printer.target to Require= since we have one 

Correctly named the service ( Previously attachment was named cupsd.service )
Comment 8 Jóhann B. Guðmundsson 2011-05-02 14:09:38 EDT
Created attachment 496325 [details]
Minor fixes to the cups socket

Added missing ListenStream=631
Comment 9 Juha Tuomala 2011-06-06 14:09:36 EDT
related bug 480668
Comment 10 Tim Waugh 2011-06-07 04:29:24 EDT
*** Bug 480668 has been marked as a duplicate of this bug. ***
Comment 11 Elad Alfassa 2011-06-19 13:34:43 EDT
*** Bug 714434 has been marked as a duplicate of this bug. ***
Comment 12 Jóhann B. Guðmundsson 2011-06-23 06:48:39 EDT
Tim can this be packaged and shipped without Lennart's patch(es) so this does not block alpha ?
Comment 13 Tim Waugh 2011-06-24 05:31:28 EDT
Good idea.
Comment 14 Tim Waugh 2011-06-29 09:23:30 EDT
I've done that.  The cups.socket bit is no good without the actual source modifications to the scheduler so I took that out for the moment.

Lennart, if you could send me the patches you have sometime that would be great.
Comment 15 Jóhann B. Guðmundsson 2011-06-29 09:32:13 EDT
Xellent we can always introduce the socket file when/if those patches from Lennart ever show up later in the development/release cycle..

Note You need to log in before you can comment on or make changes to this bug.