Bug 480828 - Zero-length pid files cause resource start failures
Zero-length pid files cause resource start failures
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
low Severity medium
: ---
: ---
Assigned To: Marek Grac
Cluster QE
:
Depends On: 474444
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-20 14:11 EST by Marek Grac
Modified: 2009-05-18 17:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 474444
Environment:
Last Closed: 2009-05-18 17:13:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marek Grac 2009-01-20 14:11:20 EST
+++ This bug was initially created as a clone of Bug #474444 +++

Created an attachment (id=325599)
Preliminary patch

config-utils.sh has check_pid_file() which is a little too zealous in its checks.

For example, if a PID file exists but is of zero length, a start for a service might fail.

This patch unlinks a zero-length PID file, since it's not useful data.  I don't know whether or not it's correct to do this generally.

This issue was first reported in bug 462910 .
Comment 3 errata-xmlrpc 2009-05-18 17:13:37 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1048.html

Note You need to log in before you can comment on or make changes to this bug.