Bug 480942 - Include kvm_stat for debugging
Include kvm_stat for debugging
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kvm (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Glauber Costa
Fedora Extras Quality Assurance
:
: 483843 (view as bug list)
Depends On:
Blocks: F11VirtTarget 483844
  Show dependency treegraph
 
Reported: 2009-01-21 09:18 EST by Mark McLoughlin
Modified: 2016-04-26 12:35 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 483844 (view as bug list)
Environment:
Last Closed: 2009-02-05 05:10:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark McLoughlin 2009-01-21 09:18:44 EST
kvm_stat is useful for diagnosing guest hangs, we should include it in the KVM package

(Also is there anything we can do to make this go away:

./kvm_stat 
Please mount debugfs ('mount -t debugfs debugfs /sys/kernel/debug')
and ensure the kvm modules are loaded

Why not mount it ourselves?
)
Comment 1 Perry Myers 2009-02-03 16:11:17 EST
*** Bug 483843 has been marked as a duplicate of this bug. ***
Comment 2 Perry Myers 2009-02-03 16:12:43 EST
Since kvm_stat is a python script perhaps we should make a subpackage for it so that we don't drag py dependencies into kvm package?  Perhaps something like kvm-stat RPM?
Comment 3 Eduardo Habkost 2009-02-04 16:40:34 EST
kvm-83-3.fc10 will contain a kvm-tools subpackage with kvmtrace and kvm_stat.
Comment 4 Mark McLoughlin 2009-02-05 05:10:50 EST
That's kvm-83-3.fc11 in rawhide

No reason no to close this now

Note You need to log in before you can comment on or make changes to this bug.